Yongnuo RF603 (for Nikon) on OM-D... Anyone tried?

Discussion in 'Accessories' started by TetonTom, Apr 23, 2013.

  1. TetonTom

    TetonTom Mu-43 Regular

    I thought that for triggering a manual flash, any standard hotshot trigger would send a signal between camera and flash. But I get nothing...
    I'm using a Metz 58AF1 (for Nikon) with good results on-camera in M and A flash modes.
    Advice or insight anyone?
     
  2. cdmicha

    cdmicha Mu-43 Regular

    74
    Dec 28, 2012
    Arkansas
    Chris
    I haven't used that brand/model of trigger, but I've had no problems with my Cowboy Studios cheapie. I've used it to trigger both a manual flash (Yongnuo 560-ii) as well as the FL-600R with no problems, and so for, no misfires. Keep in mind this is all in manual mode, I'm not sure about the semi-auto modes, but I'll try them next time I've got it set up.
     
  3. Cruzan80

    Cruzan80 Mu-43 All-Pro

    Aug 23, 2012
    Denver, Co
    Sean Rastsmith
    Have you tried the trigger with any other flash to ensure it is the Metz malfunctioning and not the trigger? Is there a TTL setting on the flash that needs to be turned off (aka. pins think it is getting more information than it does)?
     
  4. TetonTom

    TetonTom Mu-43 Regular

    I'll check my flash mode... And just to be sure I'm not being an idiot, I'm going to throw in fresh batteries all the way around.
     
  5. cdmicha

    cdmicha Mu-43 Regular

    74
    Dec 28, 2012
    Arkansas
    Chris
    Sounds like a good idea. You are right in saying that the basic manual flashes simply send a single command- and they should work on pretty much any system with a normal (looking at you, Sony!) hotshoe.

    I use the same triggers and manual flashes with my Canon and m43 gear.
     
  6. inkista

    inkista Mu-43 Veteran

    332
    Jan 13, 2012
    San Diego, CA
    The RF-603s seem to be problematic, because they're using TTL signals to set the unit into Tx (transmit) or Rx (receive) mode. Naturally, that'll be mount-system specific. (sigh). The Nikon TTL contacts are placed different from four-thirds hotshoe contacts, so there's no signal at all. This is probably also why the test button doesn't work unless the Tx unit is actually mounted on the camera hotshoe. You have to modify one unit to permanently be in Tx mode to get it to work on mft.

    The RF-602s, having separate Rx/Tx units, work just fine.

    So basically, if you don't want to mess about with soldering irons, either look for triggers that have separate Rx/Tx units (like the RF-602s), or transceivers that have an Rx/Tx switch on them (like the Cactus V5 triggers).

    I really wish that the next cheap all-manual triggers from YN would simply come with a Tx/Rx switch on them instead. Not to mention locking rings, an on/off switch on the side, where you can reach it when a flash is mounted on top, and 3.5mm sync ports for both input and output. But I'm weird.
     
  7. cstevens

    cstevens Mu-43 Veteran

    411
    Feb 11, 2010
    UK
    I am having this issue, I use YN506III which have built in receivers.

    I use RF-603's on my Nikon gear, but wanted to use the OM-D and found the 603's don't work.

    I am putting up a 'wanted' for 1 or 2 RF-602 triggers as I don't want to buy 602 'sets' when I only need the trigger part lol.