1. Reminder: Please use our affiliate links for holiday shopping!

yongnuo 468II

Discussion in 'Accessories' started by weeowee, May 19, 2012.

  1. weeowee

    weeowee Mu-43 Regular

    146
    May 6, 2012
    i have a yongnuo 468II , will this work on the omd?
     
  2. TDP

    TDP Guest

    In manual flash you should be able to get it to pop using the center contact only. Might want to use an inexpensive pc to hot shoe cable.
     
  3. weeowee

    weeowee Mu-43 Regular

    146
    May 6, 2012
    it sort of worked lastime now it doesn't on my omd but on other cams it works fine. should i just sell this and get a new flash?
     
  4. Ned

    Ned Mu-43 Legend

    Jul 18, 2010
    Alberta, Canada
    No, don't sell it - you won't get anything worthwhile from the sale. Just get a hotshoe adapter. Either a Safe Sync or a PC-Sync adapter. While you're at it, you may as well grab a flash bracket and a short PC Sync cable as well, to improve your light output even more.

    [​IMG]
     
  5. weeowee

    weeowee Mu-43 Regular

    146
    May 6, 2012
    will using the adapter make it automatic or just manual?
     
  6. Ned

    Ned Mu-43 Legend

    Jul 18, 2010
    Alberta, Canada
    Are you trying to use E-TTL or i-TTL on it right now? If so, then that's probably your problem, you gotta switch it to Manual. Which camera was this Yongnuo originally for? I'm not aware of a Four-Thirds version...
     
  7. weeowee

    weeowee Mu-43 Regular

    146
    May 6, 2012
    it was for my canon
     
  8. kkskkskks

    kkskkskks Mu-43 Rookie

    18
    Jun 7, 2012
    I have a very similar problem. I got a YN462 and it works on a GF2 but not on a OM-D. Does OM-D require specific flash units?