1. Reminder: Please use our affiliate links for holiday shopping!

Wi-Fi issue on gx7

Discussion in 'Panasonic Cameras' started by rabican, Feb 7, 2014.

  1. rabican

    rabican Mu-43 Regular

    67
    Dec 3, 2012
    My Wi-Fi keeps stopping after about 30 sec, only can transfer one or two pics. It always worked fine in the past. I tried pulling the camera battery for awhile and restarting phone...no use.

    Any thoughts?
     
  2. Pasukun

    Pasukun Mu-43 Regular

    30
    Aug 2, 2011
    Do you have any other capable device(s) that you can use it with GX7 and see if you get the same or different result? (If no, may be ask your friend's?)
    Depends on that result, you can conclude which end of the device is having a trouble.
     
  3. rabican

    rabican Mu-43 Regular

    67
    Dec 3, 2012
    I tested it on a nexus 7...seems to work fine.

    Still doesn't work on my HTC one although it used to work fine...

    I noticed my phone is version 1.8.1
    My tablet (nexus) is 1.7.2...
    Both devices are android 4.4 (newest).

    I tried clearing the cache, it's still having issues, must be the newer version, not sure how to go back though...

    Thoughts? Help?
     
  4. rabican

    rabican Mu-43 Regular

    67
    Dec 3, 2012
    I installed 1.7.2 on my phone and it's still not working so it must not be the version.

    I also updated the tablet and that's still working fine...I'm stumped. :(
     
  5. rabican

    rabican Mu-43 Regular

    67
    Dec 3, 2012
    I reset all camera WiFi settings and it didn't help...
     
  6. rabican

    rabican Mu-43 Regular

    67
    Dec 3, 2012
    This is very frustrating...I emailed Panasonic but they never replied. Guess I should call...
     
  7. arf1410

    arf1410 Mu-43 Rookie

    24
    Jan 25, 2014
    HTC One also ... same problem ...
     
  8. ginggreenaninja

    ginggreenaninja Mu-43 Regular

    32
    Dec 7, 2010
    South Yorkshire
    Have you updated the App on the phone as there have been a few additions lately.
     
  9. ex machina

    ex machina Mu-43 Top Veteran

    805
    Jan 3, 2014
    Northern Virgnia
    Fwiw, saw on another thread that renewing your lease solved a wifi user's problem -- might be worth a shot?
     
  10. rabican

    rabican Mu-43 Regular

    67
    Dec 3, 2012
    I'm not connecting to the router though, connecting directly to my phone...

     
  11. kittymama3

    kittymama3 Mu-43 Regular

    34
    Jan 20, 2014
    It was my thread where renewing the lease fixed my issue. I was connecting from my phone to the gx7's access point as well.
     
  12. ex machina

    ex machina Mu-43 Top Veteran

    805
    Jan 3, 2014
    Northern Virgnia
    Pretty sure the camera is still providing an ip address via DHCP to your phone and thus works the same way.
     
  13. rabican

    rabican Mu-43 Regular

    67
    Dec 3, 2012
    Yeah I agree ex machina.
    I couldn't find a way to renew lease on my android device so I set a static IP in which case it lost the connection to the app, when I reconnected it was auto again and it disconnected again like normal after about a minute.

    Any advise or instructions on what to do to renew lease on phone? I also don't see any settings like this in the camera...
     
  14. arf1410

    arf1410 Mu-43 Rookie

    24
    Jan 25, 2014
    Here's a thought which should be easy to test when I have a few minutes - my GX7 is new, so I am mostly playing with testing wifi (and other) features at home. Maybe my phone considers my home wifi network to be the "preferred" choice, so after being connected to the camera foor 30 seconds or so, it automatically reconnects to my home network, as I would assume it can only connect to one network at a time? so I just need to test the stability of the connection when I am out of range of my home network..
     
  15. ex machina

    ex machina Mu-43 Top Veteran

    805
    Jan 3, 2014
    Northern Virgnia
    Huh, apparently Android versions before v4.2.x have issues with ip address leases:
    http://www.net.princeton.edu/android/android-stops-renewing-lease-keeps-using-IP-address-11236.html

    A very quick look at a few Android devices I have here at the office didn't uncover a system-level way to renew the lease, unlike our iOS devices. You can "forget" the connection, but that's going to require you to reenter your credentials, a PITA. Maybe someone on the forum who is more versed in Android can help?
     
  16. arf1410

    arf1410 Mu-43 Rookie

    24
    Jan 25, 2014
    Went away from my home network, and problem was still there - phone (HTC One , Android 4.4) disconnects from Camera after about 30 seconds...
     
  17. arf1410

    arf1410 Mu-43 Rookie

    24
    Jan 25, 2014
    still can't fix this issue... :(
     
  18. ex machina

    ex machina Mu-43 Top Veteran

    805
    Jan 3, 2014
    Northern Virgnia
    Sorry no one else thus far has been able to offer help -- the only other thing I can think to suggest would be to try with a different HTC One running the same OS version to see if it's limited to your articular phone. If someone else's HTC One works fine, then you could try wiping/reinstalling yours. Good luck!
     
  19. ex machina

    ex machina Mu-43 Top Veteran

    805
    Jan 3, 2014
    Northern Virgnia
    Also, there may be apps on the Google store that allow lease-renewing.
     
  20. rabican

    rabican Mu-43 Regular

    67
    Dec 3, 2012
    Only if you root your phone.