What is wrong with this G2?

Discussion in 'Panasonic Cameras' started by InlawBiker, Sep 26, 2015.

  1. InlawBiker

    InlawBiker Mu-43 Veteran

    Feb 1, 2012
    Seattle, WA
    Real Name:
    So I came across a deal on a used G2 I couldn't pass up, but now it's having issues. I will certainly be sending it back if I can't make it work, so I wanted to run this by the group to see if anybody has seen the same thing. I suspect maybe the lens contacts are not working or something.

    The most alarming this it does is, while using AF-S or AF-C mode using my 45-175, the focus point will just vanish. When this happens I can't do anything. The camera will kind of freeze up for a second and then it will zoom all the way out to 45mm. I would say it's acting as though the camera was just powered on fresh. I thought maybe it was setting itself to manual focus mode somehow, but I can't explain the reset thing.

    It will also fail to recognize a lens sometimes. When I put on a lens it says "lens not attached properly" or something like that.

    Since both lenses work fine on my GX7 I know it's not the lenses. Anybody seen these symptoms before?

  2. tkbslc

    tkbslc Mu-43 Hall of Famer

    Dirty contacts? Try rubbing all the metal electrical contact in the camera mount with a regular pencil eraser.
  3. InlawBiker

    InlawBiker Mu-43 Veteran

    Feb 1, 2012
    Seattle, WA
    Real Name:
    I tried it we'll see what happens. It is funny that no Micro 4/3 cameras have been around long enough to have long-term problems like this, until now maybe. Anyhow hopefully it will be resolved I want to keep this camera.

  4. Klorenzo

    Klorenzo Mu-43 All-Pro

    Mar 10, 2014
    I'd also try to update the firmware on the camera and the lens.
  5. Ulfric M Douglas

    Ulfric M Douglas Mu-43 Hall of Famer

    Mar 6, 2010
    Hmmm. Perhaps it's the combination of G2, old contacts (clean and check each for springiness) and a lens which was released long after the G2 was made ... perhaps there are signals to/from the 45-175 which do not make sense to the G2 body.
    I know lenses and bodies can do more stuff than they did back in G2 days.

    Also change your focus box choice and maybe this dodgy behaviour will go away. Does it do that in S-AF, centre point only? In 'all focus points'? Maybe there's a choice to solve your problem.
  6. b_rubenstein

    b_rubenstein Mu-43 All-Pro

    Mar 20, 2012
    Melbourne, FL
    Big boy, grown up, companies do regression testing to avoid this sort of thing. Not to mention that ยต4/3 has standards that will do things to avoid this problem. This is not a Sigma situation where they won't pay licensing fees to camera makers, reverse engineer interface specifications and then sell lenses that don't always work right with new cameras.