Weirdness with Leica lenses on GX1 & GX7

Discussion in 'Panasonic Cameras' started by EricRose, Jun 28, 2016.

  1. EricRose

    EricRose Mu-43 Regular

    100
    Jul 2, 2014
    The upper 12
    Eric Rose
    I have used my Summicron 50mm and 90mm lenses on my GX1 with great results. However if I use them on my GX7 I get all kinds of chromatic yuk plus the images are out of focus. I am using focus peaking etc. and it shows things should be in focus.

    Any suggestions? BTW my Nikon glass works just fine on my GX7.

    The Leica lens work fine on both my M4 and M5.
     
  2. agentlossing

    agentlossing Mu-43 Hall of Famer

    Jun 26, 2013
    Andrew Lossing
  3. EricRose

    EricRose Mu-43 Regular

    100
    Jul 2, 2014
    The upper 12
    Eric Rose
    I thought I described the problem quite well but in any case here are some images. No processing has been done to either of them.

    This is 100% crop
    ericgrose_saltery_bay_90mm_crop_sm.

    Full Frame
    ericgrose_saltery_bay_90mm_sm.
     

    Attached Files:

    Last edited: Jul 2, 2016
  4. EricRose

    EricRose Mu-43 Regular

    100
    Jul 2, 2014
    The upper 12
    Eric Rose
    Last photo was taken with Panasonic 100-300 and cropped.
     
  5. tkbslc

    tkbslc Mu-43 Hall of Famer

    I think you are just out of focus. Peaking isn't as accurate as you would hope. Try it with the magnifier box and I bet it looks better.
     
    • Agree Agree x 1
  6. EricRose

    EricRose Mu-43 Regular

    100
    Jul 2, 2014
    The upper 12
    Eric Rose
    Well I put the camera on a tripod and used the magnify box. All the images turned out perfect. I guess trying to focus and shoot from a rocking boat is not my strong suit. On another note I expected diffraction by f11 but I was able to get good sharp pics right up to f16. Nice to know. F8 was the sharpest aperture which was no surprise.
     
    • Like Like x 1