Viltrox JY-43F 4/3 Adapter - Defective?

Discussion in 'Adapted Lenses' started by Levster, Oct 10, 2014.

  1. Levster

    Levster Mu-43 Top Veteran

    I have recently acquired an Olympus 50-200mm SWD lens and also bought a cheapish 4/3 Adapter (model: Viltrox JY-43F). There seems to be an issue where the rear screen of my EM-1 will no longer display the live view image and the only way to get it back is to reboot the camera. I have noticed an element of play in the camera/lens/adapter combination and the screen only goes blank if I turn the zoom ring in a clockwise direction and get to the 50mm end. Could it be that the contacts are losing contact when the whole assembly twists? And, is it likely to be resolved by buying a new 4/3 Adapter?
  2. dougjgreen

    dougjgreen Mu-43 All-Pro

    Jun 5, 2013
    San Diego
    Real Name:
    Doug Green
    Well, I have a working just fine Viltrox 4/3 to Micro 4/3 adapter. But I must admit, I've never used it on any lens as heavy as the 50-200 - I use mine on the 14-54 and 11-22 lenses.
  3. Levster

    Levster Mu-43 Top Veteran

    Maybe that's what it is, the torque when turning the lens is twisting the whole assembly. Unfortunately it makes the lens unusable because I can only zoom in!
  4. Itchybiscuit

    Itchybiscuit Photon Mangler

    Dec 10, 2013
    Glasgow, Scotland
    Real Name:
    I use the same adapter for my Olympus 4/3rds lenses both 40-150mm - the f3.5 and f4 versions - and I've had no issues at all on my G5. :thumbup:
  5. edmsnap

    edmsnap Mu-43 Veteran

    Dec 20, 2011
    Edmonton, Alberta
    There another thread here discussing the same thing. Viltrox has, in my experience, some real quality control problems. I and many others have had the exact same problem. The good news is that your lens is completely fine. The other good news is that buying a better adapter will completely fix your problem.
    • Like Like x 1