1. Reminder: Please user our affiliate links to get to your favorite stores for holiday shopping!

Using Pocket Wizard's nikon tt5 and tt1 with om-d

Discussion in 'Lighting Forum' started by om-d freak, Jul 15, 2012.

  1. om-d freak

    om-d freak New to Mu-43

    5
    Jul 11, 2012
    Irvine, Calif.
    Has anyone tried to get the pocket wizard tt-5 and tt-1 radio's with a Olympus OM-D? PW says you can set up as trigger only, yet I have not had any luck getting them to fire my nikon flashes. I have set the radio's up in "Trigger only mode", yet no firing of the flashes!!!
     
  2. Sammyboy

    Sammyboy m43 Pro

    Oct 26, 2010
    Steeler Country
    They will not work, the communication pins are in different locations.
     
  3. om-d freak

    om-d freak New to Mu-43

    5
    Jul 11, 2012
    Irvine, Calif.
    I think the center pin on both cameras(oly and Nikon, as well as Canon's) are for a trigger only. In looking at other "radio" type remotes, they all have the center pin in common, Most only the center pin. Also, when I mount the nikon flash's on top of the oly, they fire in manuel mode.
     
  4. JJJPhoto

    JJJPhoto Mu-43 Veteran

    252
    Jul 8, 2011
    Cincinnati, OH
    Jerry Jackson Jr
    They work fine ... but only in "Basic Trigger Mode" which makes the MiniTT1 and FlexTT5 work like a standard PocketWizard trigger and transceiver. As previously mentioned, you can't make the MiniTT1 and FlexTT5 work in TTL mode with the Olympus TTL metering system because the hotshoe pins and communication protocols are different.

    I use the MiniTT1, FlexTT5 and AC3 controller with Nikon speedlights on a Nikon DSLR and they're great. I sometimes use the TT1 and TT5 on my Olympus 4/3 and m4/3 cameras but, again, they only work in Basic Trigger Mode.

    If you are having trouble try resetting the TT1 and TT5, set up Basic Trigger Mode on both, make sure the flashes are set to manual or auto (not TTL), and be prepared to possibly change the radio channel if they aren't working due to interference.
     
  5. om-d freak

    om-d freak New to Mu-43

    5
    Jul 11, 2012
    Irvine, Calif.
    Thanks for your response Jerry. I have tried exactly what you said, and the both the mini, and the tt5 respond with a red light when the shutter is fired on the om-d. Next stop --PW tech support!!!
     
  6. om-d freak

    om-d freak New to Mu-43

    5
    Jul 11, 2012
    Irvine, Calif.
    Jerry,
    Just figured out the problem, and problem solved. On c2, the send and receive channels were different. Duh!!!!! Just played with a few test shots, work's perfect.
    Thanks:wink::wink: