Unable to load mu-43 with uBlock in Firefox

robcee

Mu-43 Top Veteran
Joined
Jan 10, 2016
Messages
731
Location
New Brunswick, Canada
Real Name
Rob Campbell
Hi.

A recent change has made mu-43 unusable with uBlock origin in Firefox. Whether it's due to cross-site scripting or blocking a 3rd party site from use, the forum software is throwing errors when these scripts aren't loaded.

While I support the site and have been a subscriber for 2+ years, forcing users to run 3rd party javascript from questionable advertising providers isn't a great look in my opinion.

With uBlock origin enabled:

Screenshot 2021-04-11 114116.png
Subscribe to see EXIF info for this image (if available)


list of advertisers and trackers pulled in when trying to load:

Screenshot 2021-04-11 114143.png
Subscribe to see EXIF info for this image (if available)


note, everything below mu-43.com is an advertiser or tracker. Ezoic.* appears to be whatever's preventing the site from loading.
 

Amin Sabet

Administrator
Joined
Apr 10, 2009
Messages
11,095
Location
Boston, MA (USA)
forcing users to run 3rd party javascript from questionable advertising providers isn't a great look in my opinion.

I did not make any recent changes to any advertising providers, nor have I intentionally done anything to try and force anyone to view ads or disable ad blocking.

The only recent change I made was updating our Xenforo forum software to the latest version and updating our necessary plugins to be compatible with that.

That said, I don't have time to troubleshoot why the site doesn't support every third party browser or ad blocking software.

At this point, I'm providing the site more because I haven't found someone to do a good job of taking it over than for any other reason. I don't even do much photography anymore. If it didn't mean disappointing a lot of people, I would just shut down the site.
 

robcee

Mu-43 Top Veteran
Joined
Jan 10, 2016
Messages
731
Location
New Brunswick, Canada
Real Name
Rob Campbell
Hey Amin,

I was merely bringing it to your attention. Oddly, I'm not seeing the issue on my laptop so something might be different between my two machines or the script is doing something differently.

weird. 🤷‍♂️
 

BosseBe

Mu-43 Hall of Famer
Joined
Aug 7, 2015
Messages
3,934
Location
Stockholm, Sweden
Real Name
Bo
At this point, I'm providing the site more because I haven't found someone to do a good job of taking it over than for any other reason. I don't even do much photography anymore. If it didn't mean disappointing a lot of people, I would just shut down the site.
@Amin Sabet I would be very sad if this site disappeared!
Please let us know anything we can do to keep it running!
 

John King

Mu-43 Hall of Famer
Joined
Apr 20, 2020
Messages
2,648
Location
Beaumaris, Melbourne, Australia
Real Name
John ...
Hi.

A recent change has made mu-43 unusable with uBlock origin in Firefox. Whether it's due to cross-site scripting or blocking a 3rd party site from use, the forum software is throwing errors when these scripts aren't loaded.

While I support the site and have been a subscriber for 2+ years, forcing users to run 3rd party javascript from questionable advertising providers isn't a great look in my opinion.

With uBlock origin enabled:

View attachment 882603

list of advertisers and trackers pulled in when trying to load:

View attachment 882604

note, everything below mu-43.com is an advertiser or tracker. Ezoic.* appears to be whatever's preventing the site from loading.
Rob, I use Adblock Plus with Firefox, backed up by MalwareBytes (paid) edition. I have zero problems with any genuine site, and I want the dodgy ones blocked!

Also, I only have standard ports open on my internet modem/router. This is overlooked by many.

It has been over 20 years since I have had any poxware on any of our computers.
 

whereSs

New to Mu-43
Joined
Aug 7, 2020
Messages
8
It does this with uBlockOrigin (in Firefox) as well, but you can just disable the blocking for this site and it's A-OK.

I don't think it's that big of a deal.
 

whereSs

New to Mu-43
Joined
Aug 7, 2020
Messages
8
I'm only ever accessing mu-43 via a private window, or more precisely, a dedicated container tab. Any advertising/tracking/cookies on their end don't travel to other websites, because it's all self-contained.

(Container tabs are a killer feature!)
 

robcee

Mu-43 Top Veteran
Joined
Jan 10, 2016
Messages
731
Location
New Brunswick, Canada
Real Name
Rob Campbell
I'm only ever accessing mu-43 via a private window, or more precisely, a dedicated container tab. Any advertising/tracking/cookies on their end don't travel to other websites, because it's all self-contained.

(Container tabs are a killer feature!)

yeah, I love them and use the multi-account container addon all the time, though hadn't considered it for this site. I usually just browse it in my Personal container or no container by default. I wouldn't normally use a Private window for browsing a site I visit all the time, but will probably put it into a separate container now that you mention it. cheers!
 
Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Mu-43 is a fan site and not associated with Olympus, Panasonic, or other manufacturers mentioned on this site.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Forum GIFs powered by GIPHY: https://giphy.com/
Copyright © Amin Forums, LLC
Top Bottom