TWO dead E-PL5s in TWO YEARS!

Discussion in 'Olympus Cameras' started by CanonConvert, Jan 10, 2017.

  1. CanonConvert

    CanonConvert Mu-43 Regular

    Nov 22, 2012
    Two years ago, my E-PL5 had this issue:

    Back then, I asked around but no one had an inkling why the body responded like that. I bought a new E-PL5, and 2 years ago, the same thing happened:

    I have tried resetting all settings to default, changing different lens, different modes, different cards/batteries and it still shows the same problem. May I know what exactly is wrong with the camera and how can I resolve it?

    Thanks in advance for your help!
  2. Cederic

    Cederic Mu-43 Veteran

    Nov 14, 2012
    I haven't encountered that issue with mine. Perhaps contact Olympus support?
  3. CanonConvert

    CanonConvert Mu-43 Regular

    Nov 22, 2012
    they aren't willing to tell me the problem until i send for diagnostics, with $60 labour fee.

    just want to make sure it's nothing serious before i send it in.
  4. rich.smith

    rich.smith Mu-43 Regular

    Dec 21, 2011
    I had the same issue with my E-M10. It was the shutter sticking. Take off the lens and see if the shutter sticks closed. I sold my E-M10 for parts when that happened so I don't know the repair cost.
  5. CanonConvert

    CanonConvert Mu-43 Regular

    Nov 22, 2012
    it gets closed for 5 seconds, and opens up thereafter.

    any advice and if I can DIY the shutter replacement? can't find the parts on eBay.
  6. djtaylor7

    djtaylor7 Mu-43 Veteran

    Mar 2, 2013
    Nelson, NZ
    Strange for the same fault to happen on two bodies. If you had not tried different cards I would have wondered if it was a corrupted memory card. I imagine getting into the camera to get to the shutter will be almost a complete strip down. Can see a CCD sensor and mirror box frame on eBay from rongyuanxie, but not aware if the latter includes the shutter. Life Pixel give some good tutorials of how the get into Olympus cameras:
    Life Pixel – Olympus E-PL5 DIY Digital Infrared Conversion Tutorial - LifePixel Digital Infrared Photography IR Conversion.
  7. Christop82

    Christop82 Mu-43 Top Veteran

    Sep 10, 2016
    I had this problem on a epl1. The shutter was stuck open. I put it in fireworks mode, and while shooting I tapped around the body with a rubber handle. Pull battery and repeated until it broke free. Once free, I placed camera in continuous shooting mode and went to town. Maybe this can help someone else.
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.