So what exactly was the problem with the E-M10 Mark II?

Discussion in 'Olympus Cameras' started by So Thankful, Oct 22, 2015.

  1. So Thankful

    So Thankful Mu-43 Veteran

    232
    Jun 9, 2015
    Midwest
    I am looking to get my wife a camera for Christmas. I am thinking a E-M10 Mark II.
    What I want to know is why Olympus had to pull it from it's original launch date? What do I need to look for to make sure the camera I get her is working properly?
     
  2. Sammyboy

    Sammyboy m43 Pro

    Oct 26, 2010
    Steeler Country
    The lens locking pin had a rough surface that could wear the lens flange of plastic lenses .....
     
  3. So Thankful

    So Thankful Mu-43 Veteran

    232
    Jun 9, 2015
    Midwest
    Oh OK that should have been an easy fix and will be easy to check once I get her camera.
    Just saw B&H has the black one with kit lens in stock.
     
  4. Carbonman

    Carbonman Mu-43 All-Pro

    Jul 10, 2014
    Vancouver BC
    Graham
    There's nothing to worry about with the issue that stopped sales; it's all fixed now. I recommend you set up the SCP for her so she doesn't go nuts initially trying to figure out how to make the camera work.
     
    • Agree Agree x 1
  5. So Thankful

    So Thankful Mu-43 Veteran

    232
    Jun 9, 2015
    Midwest
    She has used my E-M5 but I will help her learn the camera. I am teaching her photography. She has a great eye she just needs trained on the technical stuff.
     
  6. gary0319

    gary0319 Mu-43 Veteran

    302
    Nov 26, 2014
    Sarasota FL
    Great camera, your wife will love it. I returned mine because of the lens mount issue, but those units should be about cleared from the supply chain by now. Give B&H a call and they can tell you if there is still a chance you could get a bad one. they'll give you the straight goods.
     
    • Agree Agree x 1