1. Reminder: Please user our affiliate links to get to your favorite stores for holiday shopping!

So I dropped my OMD EM10 and am experiencing a couple problems.

Discussion in 'Hardware' started by nerkidner, Mar 4, 2015.

  1. nerkidner

    nerkidner New to Mu-43

    3
    Mar 4, 2015
    Hi all,

    New to the forum so bear with me. I am on month two of a six month trip and I have dropped my OM-D EM-10 on a ceramic floor (only about a half meter!) and now when turned on I get three shutter clicks, the shutter locking, no information other than black lit screen on LCD, and the camera powering off after a few seconds.

    The shutter will lock in place which can be seen after taking of the lens. I've tried multiple lenses and am getting the same effect. I've also searched this forum and the rest of the internet in hopes of a fix but there is virtually no info anywhere on hardware fixes.

    Does anyone have any ideas as to how to fix? Thanks so much in advance.
     
  2. tkbslc

    tkbslc Mu-43 Hall of Famer

    It seems fairly obvious that the shutter mechanism was knocked out of alignment or damaged from the drop. Unfortunately it's going to need some repair.

    Where are you traveling?
     
  3. nerkidner

    nerkidner New to Mu-43

    3
    Mar 4, 2015
    Traveling in South East Asia at the moment. I'm assuming I'll have to ship to Olympus but don't know which office. I think there is Japan and US.

    Do you know if the shutter alignment fix would be expensive? Would it be covered under first year warranty?

    Thanks for the help!
     
  4. myminpins

    myminpins New to Mu-43

    1
    May 24, 2015
    Brenda Dobson
    nerkidner, did you ever figure out what was wrong with your camera? I have the same issue after a very small drop and I need it fixed NOW... did you have to send it in? Was it expensive? Did it take a long time?

    Thank you!!!!!
     
  5. agentlossing

    agentlossing Mu-43 Hall of Famer

    Jun 26, 2013
    Andrew Lossing
    I just had to have the same thing repaired. Dropped the EM10, shutter stuck closed and screen went black. Would reset when switched off and on, but shutter never reopened when trying to take a shot, and the file was never recorded. Sent it in to Olympus US and $160 later it was fixed. About a 2 week turnaround, much of which was shipping time.
     
    • Like Like x 3
  6. nerkidner

    nerkidner New to Mu-43

    3
    Mar 4, 2015
    I did actually! It was within the warranty so even tthough I dropped it they fixed it free of charge (in Canada). It took a little while but I bought the EM5 Mk2 in the meantime so was not too bent out of shape :)
     
    • Like Like x 1
  7. Theo

    Theo Mu-43 Veteran

    318
    Aug 26, 2013
    Canada
    Theo K.
    I'm surprised that a drop is covered under warranty.
     
    • Agree Agree x 1
  8. Harvey Melvin Richards

    Harvey Melvin Richards Photo Posting Junkie

    Feb 15, 2014
    Southwest Utah
    My E-M10 suffered the same fate yesterday. It will be going in for repair, but a new silver body E-M10 will be here on Wednesday. Luckily camera #2 was only $450.
     
  9. pajo

    pajo Mu-43 Rookie

    22
    Mar 11, 2013
    It happened to my em10 about 2 month ago. Didn't dropped the camera. I was taking photos and the camera failed between shoots. Sent to repair, cost £130, luckily the camera is under warranty.
     
  10. agentlossing

    agentlossing Mu-43 Hall of Famer

    Jun 26, 2013
    Andrew Lossing
    What's with this rather sudden plunge in reliability of the EM10 shutter? I can't say I saw these kinds of issues until mine developed it, now there's a depressing amount of others chiming in.
     
  11. twokatmew

    twokatmew Mu-43 All-Pro

    Jun 1, 2012
    Lansing, MI, US
    Margaret
    Hmmm. I have two, one's still under warranty. I fell with my first in my hand, and the camera smacked the pavement, shattering the LCD. Everything still worked (even the LCD), but I sent it to Precision for (out of warranty) repair. I bought a second E-M10, and so far both are just fine, save a small ding on the body of the one I had in my hand when I fell. Fingers crossed neither develop this problem.
     
  12. ashburtononline

    ashburtononline Mu-43 Veteran

    388
    Jan 21, 2015
    New Zealand
    I dropped my Em1 with 40-150 and battery pack onto a wooden floor from 1 metre and other that a smashed lens hood, everything is fine! I was shooting a wedding at the time too .... Embarrassing:)
     
  13. kgeissler

    kgeissler Mu-43 Regular

    108
    Oct 25, 2012
    Rowlett, TX
    Just another person chiming in on this. Dropped my EM10 today from about one foot and now have the same problems as OP. Will call Olympus tomorrow.
     
  14. Harvey Melvin Richards

    Harvey Melvin Richards Photo Posting Junkie

    Feb 15, 2014
    Southwest Utah
    My E-M10 was 14 months old when the shutter quit working, luckily I had purchased an additional 2 year warranty and it was repaired no charge. I was only out the shipping. Mine took about 2 1/2 weeks to get back to me.
     
  15. agentlossing

    agentlossing Mu-43 Hall of Famer

    Jun 26, 2013
    Andrew Lossing
    This is a pretty serious problem, one which I hadn't heard much of until it happened to me. Sad that anything can temper my enthusiasm for this amazing camera, but it's a real issue :(
     
  16. kgeissler

    kgeissler Mu-43 Regular

    108
    Oct 25, 2012
    Rowlett, TX
    What is the length of the warranty on the EM10?

    Also for some reason, when I registered mine, I thought I got an extra 3 or 6 months of warranty coverage. I could be losing my mind though. Is there anyway to check my warranty coverage on Olympus's website?
     
    Last edited: Jul 7, 2015