Site upgrade feedback, bugs, and requests thread

Status
Not open for further replies.

Cederic

Mu-43 Top Veteran
Joined
Nov 14, 2012
Messages
556
Location
Nottingham
I'm missing the homepage and trying to adjust to the orange in the dark theme but it's all working fine, doing all the things I expected and hoped. Thank you.

One change nobody commented on is how the likes/wows/funny/appreciate/etc indications on a post are both made and displayed now. I preferred the old approach of showing the various options from the outset (rather than hiding them behind a 'Like' button, something I've been programmed to ignore) and I'm finding I like both the old way of showing how many of each various response there were ("8 likes, 2 wows and 3 winners? That's good!") and the new one that tells me who's shared their feedback.

It's silly but those little icons with their counts made the whole site more friendly and allowed a broader range of responses; I fear the new system will lose some of that as people merely click 'Like', a more bland response.
 

pdk42

One of the "Eh?" team
Joined
Jan 11, 2013
Messages
6,554
Location
Leamington Spa, UK
I must say, I'm not digging this new look. Maybe I'll get used to it, but at the moment I'm really missing the old site. The move to Zenforo from vBulletin was immediately a massive improvement, but I'm feeling now that we've stepped backwards.
 

Jeffcs

Mu-43 All-Pro
Joined
Jan 20, 2017
Messages
1,332
Location
Toms River NJ
Dear all,

Tomorrow I will begin the long process of upgrading the site from Xenforo 1.x to Xenforo 2.x. The site has been backed up carefully, and I've run the upgrade process on a test site.

Still, I expect that there will be some bumps in the road. Initially, I'm going to install the forum software without a lot of addons/modifications in order to make sure everything is working. That means that there won't be a front page with featured threads, a sidebar with recent discussions in the thread view, an alert at the top of the page for unread threads, direct menu links to Buy & Sell, or certain other features you may be accustomed to.

Addons which have priority are the enhanced search, the Buy & Sell feedback system, getting the post ratings system imported (likes, thanks, winner, etc). In time I will add back other features as time permits. Some, like the featured threads front page, will definitely be restored. Others may stay gone depending on member request and feasibility within Xenforo 2.x.

When the site first switches over, there will only be one site theme/style. I will restore the ability to use light or dark styles, fix logos, etc, over the course of the next couple of days.

Please use this thread to point out any bugs, requests, or suggestions. I do ask that you be patient with me. I am doing this alone rather than paying someone because I feel like I am in the best position to get it right, but I've got a hectic job and family life, so it will take me some time to get everything squared away.

Addendum: I may not be able to respond directly to every comment or suggestion, but I am reading everything. There are a lot of basic things I need to get done behind the scenes before I get to some of the requests.
I like the up-grade for most part I miss the “go back button”
 

retiredfromlife

Mu-43 Hall of Famer
Joined
May 15, 2016
Messages
3,579
Location
Sydney, Australia
I'm missing the homepage and trying to adjust to the orange in the dark theme but it's all working fine, doing all the things I expected and hoped. Thank you.

One change nobody commented on is how the likes/wows/funny/appreciate/etc indications on a post are both made and displayed now. I preferred the old approach of showing the various options from the outset (rather than hiding them behind a 'Like' button, something I've been programmed to ignore) and I'm finding I like both the old way of showing how many of each various response there were ("8 likes, 2 wows and 3 winners? That's good!") and the new one that tells me who's shared their feedback.

It's silly but those little icons with their counts made the whole site more friendly and allowed a broader range of responses; I fear the new system will lose some of that as people merely click 'Like', a more bland response.
I agree, viewed a few posts and could work out the new rating system and have not used it yet. Hopfully it will be improved
 

Amin Sabet

Administrator
Joined
Apr 10, 2009
Messages
10,847
Location
Boston, MA (USA)
Sorry don’t like the changes!
To me... it seems a step backward from a usability standpoint.
I must say, I'm not digging this new look. Maybe I'll get used to it, but at the moment I'm really missing the old site. The move to Zenforo from vBulletin was immediately a massive improvement, but I'm feeling now that we've stepped backwards.
The previous version of Xenforo is approaching end of life in terms of security updates, so I had no option other than to upgrade to the new version. Over time, I will try and improve the functionality of this version.
 

wjiang

Mu-43 Legend
Joined
Sep 7, 2013
Messages
7,110
Location
Christchurch, New Zealand
The previous version of Xenforo is approaching end of life in terms of security updates, so I had no option other than to upgrade to the new version. Over time, I will try and improve the functionality of this version.
I for one apprentice the efforts. Yes it's a work in progress but we'll get there. Definitely agree on prioritising the front page and usability features.

I'm struggling a little with the orange though :p
 

wjiang

Mu-43 Legend
Joined
Sep 7, 2013
Messages
7,110
Location
Christchurch, New Zealand
What is a UI buffer?
He probably means the new site is heavier on JS and what not, so uses more resources. I have noticed that a little as well.

One thing that has tripped me up a few times now is that trying to scroll past the reply controls at the bottom of a thread is more difficult on a phone - if the OSK activates, there's very little dead space for scrolling, and I end up activating one of the many buttons at the top of the reply controls instead.
 

wjiang

Mu-43 Legend
Joined
Sep 7, 2013
Messages
7,110
Location
Christchurch, New Zealand
What does that mean?
On Screen Keyboard. If I accidentally touch inside the reply text box it activates and shrinks the browser so it pretty much just shows the reply controls and text box. I'm not sure why it's more of a problem for me now than before though.

I haven't been able to find a way in Xenforo 2 to make a front page like the one we had in Xenforo 1. For now, I've added a featured threads slider at the top of the forum index.
Any way to hide the title overlay or at least move it below the image? It obscures half the image in a lot of cases. It's made worse by the aspect ratio of the preview space- everything gets cropped into what looks like 3:2, ironically chopping off the bottom of 4:3 images which are the predominant aspect ratio of this system. I feel like letter boxing would have been a better option.
 
Last edited:

Ross the fiddler

Mu-43 Hall of Famer
Joined
May 20, 2012
Messages
3,717
Location
Blue Mountains, NSW, Australia
Real Name
Ross
The NBN isn't likely to be rolled out here for at least 12 months so most are stuck with ADSL
Posts with multiple images are loading fine with ADSL for us (using Win7 & Google Chrome browser). We've got the modem to install to trigger the NBN connection process (to the curb) but we're putting it off because ADSL is fine for us with analogue phone use still.
 

Brownie

Mu-43 All-Pro
Joined
Sep 3, 2018
Messages
1,113
Location
SE Michigan
Real Name
Tim
This place is great. I've learned more about the idiosyncrasies of M/43 in a much shorter time frame than would be possible anywhere else. The staff is great, members are mostly straight shooters, and there's enough talent here to impress anyone. I very much appreciate the effort that it takes to keep this place going and updated. Putting my $ where my mouth is, I've subscribed. Should've done it long ago.

Amin, probably not a recurring problem, but my first post this morning showed the person I replied to was on my ignore list. I don't have an ignore list. It hasn't happened since, but thought you may want to know in case others mention it.
 

archaeopteryx

Gambian sidling bush
Joined
Feb 25, 2017
Messages
1,067
Me as well on the orange. I'm not much for light themes and appreciate a dark theme was quickly returned, but the previous dark theme was less colourful and seemed to me to distract from images less. It's a small thing and low priority, but hopefully it's also a small edit to the theme definition. An exact match to the previous dark theme isn't IMO important, but a chunk closer would be nice.

I'm a subscribing member but am getting "Subscribe to see EXIF info" on images rather than the EXIF. Not sure if that's currently expected and, personally, it's something I pay little attention to. I know it matters more to others, though.

While the latest posts sidebar has been restored, the Unread Posts page now has a filter drop down at top right with some options for watched threads and such. May be worth checking out for some.

Seems XenForo 2.x may take more advantage of browser caching than 1.x. If that helps cut bandwidth costs, great. As an awareness thing, at least in Chrome I'm finding pages need manual refreshes to pick up changes in slightly different cases than in 1.x.

[Edited to update to current behavior and relate to a couple points mentioned by others downthread.]
 
Last edited:

Brownie

Mu-43 All-Pro
Joined
Sep 3, 2018
Messages
1,113
Location
SE Michigan
Real Name
Tim
For those missing the new posts sidebar, I think the Unread Posts page is the closest equivalent currently available. Based on some of the past threads and some of the observations about watched threads here, I would suggest the filters drop down at the top right of the Unread Posts page may be worth checking out for some.
The new posts sidebar is back, at least I have it.
 

archaeopteryx

Gambian sidling bush
Joined
Feb 25, 2017
Messages
1,067
The new posts sidebar is back, at least I have it.
And I got a push alert for your reply, so apparently that's back too. Not seeing the browser tab icon update with the alert count as it did with 1.x, though.

Edit: Push alerts are gone again.
Edit: Now they're back and the tab title starts with (n), where n is the alert count.
Edit: Either push alerts are gone again or they only work on certain pages.
Edit: Another possibility is pushes might not occur once a browser tab has been idle for a certain amount of time. It may also be they don't recover if the tab is used later.
Edit: Alerts from some threads appear to be getting dropped (>17 minute latency, alerts from other watched threads in <1 minute, alerts from other threads delivered in response to posts made after posts in the non-alerting thread).
Edit: Zero of nine alerts pushed over the past few hours. In the last few minutes only three of five pushed. For example, this post of Amin's generated an alert that didn't push. Same for this post and this post.
 
Last edited:

Jeffcs

Mu-43 All-Pro
Joined
Jan 20, 2017
Messages
1,332
Location
Toms River NJ
Dear all,

Tomorrow I will begin the long process of upgrading the site from Xenforo 1.x to Xenforo 2.x. The site has been backed up carefully, and I've run the upgrade process on a test site.

Still, I expect that there will be some bumps in the road. Initially, I'm going to install the forum software without a lot of addons/modifications in order to make sure everything is working. That means that there won't be a front page with featured threads, a sidebar with recent discussions in the thread view, an alert at the top of the page for unread threads, direct menu links to Buy & Sell, or certain other features you may be accustomed to.

Addons which have priority are the enhanced search, the Buy & Sell feedback system, getting the post ratings system imported (likes, thanks, winner, etc). In time I will add back other features as time permits. Some, like the featured threads front page, will definitely be restored. Others may stay gone depending on member request and feasibility within Xenforo 2.x.

When the site first switches over, there will only be one site theme/style. I will restore the ability to use light or dark styles, fix logos, etc, over the course of the next couple of days.

Please use this thread to point out any bugs, requests, or suggestions. I do ask that you be patient with me. I am doing this alone rather than paying someone because I feel like I am in the best position to get it right, but I've got a hectic job and family life, so it will take me some time to get everything squared away.

Addendum: I may not be able to respond directly to every comment or suggestion, but I am reading everything. There are a lot of basic things I need to get done behind the scenes before I get to some of the requests.
Two other items missing that I likes is the amount of posts and the ratings and the “go back button”
 
Status
Not open for further replies.

Latest posts

Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Mu-43 is a fan site and not associated with Olympus, Panasonic, or other manufacturers mentioned on this site.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Copyright © 2009-2019 Amin Forums, LLC
Top Bottom