1. Reminder: Please user our affiliate links to get to your favorite stores for holiday shopping!

Sigma 30mm aperture blades rattle (with video)

Discussion in 'Native Lenses' started by Sevandija, May 29, 2012.

  1. Sevandija

    Sevandija Mu-43 Rookie

    10
    May 29, 2012
    Portugal
    Hi, just received this lens today and have been shooting with it.

    I'm very pleased with the pictures quality but this rattling sound is very suspicious.

    I'm aware that with the camera off there should be some loose elements rattling inside the lens but this is not the case.

    If you could just see the video and give me some advice while I can exchange this for another copy, it would be great. Thank you in advance

    P1000611.MP4 - YouTube
     
    • Like Like x 1
  2. EP1-GF1

    EP1-GF1 Mu-43 Veteran

    312
    Apr 12, 2011
    Welcome!

    I suspect that sound is normal - the 20mm and 14mm do something similar on my Olympus cameras. The 25mm is well known for it too - if you google 25mm and rattlesnake you'll be reading for hours!

    I'm sure some veterans will be along shortly to give their advice though.
     
  3. ageha

    ageha Mu-43 Regular

    64
    Jun 14, 2011
    I'm surprised it's not only a Panny issue. :(
     
  4. ean10775

    ean10775 Mu-43 All-Pro

    Jan 31, 2011
    Cleveland, Ohio
    Eric
    That's normal with a lot of lenses on Olympus bodies and it isn't just limited to non-Oly lenses - the Oly 17mm f2.8 did it on my E-PL1 as well
     
  5. ageha

    ageha Mu-43 Regular

    64
    Jun 14, 2011
    Seriously? The 17mm F2.8 is quiet on my OM-D.
     
  6. rich00

    rich00 Mu-43 Veteran

    251
    Dec 8, 2011
    I have both 19 and 30, it's the same on both of them. I would most likely say it's the live view in particular sunny conditions that's causing the aperture adjust frequently. I wouldn't worry about it, as long as it takes a good picture.
     
  7. ageha

    ageha Mu-43 Regular

    64
    Jun 14, 2011
    So with the EVF in use it doesn't happen?
     
  8. rich00

    rich00 Mu-43 Veteran

    251
    Dec 8, 2011
    I currently use the vf-3 and it still rattles. I didn't realize your post was about video use. Which this lens is supposed to be quite in this case. I will carry out some testing and let you know.
     
  9. rich00

    rich00 Mu-43 Veteran

    251
    Dec 8, 2011
    ok, let me start again. I didn't read the OP and just viewed the video.
    Yes the lens still rattles when using an EVF, as mentioned previously it occurs when changing from bright to low light as you've demonstrated. It doesn't affect the performance of the lens, not sure how this in vide mode.
     
  10. Sevandija

    Sevandija Mu-43 Rookie

    10
    May 29, 2012
    Portugal
    Thank you all for your answers. I'm glad that I don't have to send the lens back because I'm really enjoying the pictures and it balances well with my E-PL1.

    And it is not really a big problem. In a busy environment you don't hear the sound, just when everything is quiet.

    At least this problem made me discover this forum that I will be visiting often

    :2thumbs::43: Thank you
     
    • Like Like x 2