Sensor cleaning on E-M10

Discussion in 'Olympus Cameras' started by GShooter, Mar 28, 2014.

  1. GShooter

    GShooter Mu-43 Regular

    How is sensor cleaning carried out on the E-M10? Other cameras I have owned had a censor cleaning mode somewhere in the menu but I havn't been able to find one on this camera.
     
  2. dombi

    dombi Mu-43 Regular

    38
    Oct 30, 2013
    I think I read it somewhere that the E-M10 does not have that feature.
     
  3. dhazeghi

    dhazeghi Mu-43 Hall of Famer

    Aug 6, 2010
    San Jose, CA
    Dara
    The sensor shaker automatically runs every time you turn the camera on. There's no way to manually run it.
     
  4. gugarci

    gugarci Mu-43 Veteran

    304
    Jul 8, 2012
    Lyndhurst, NJ
    Bill
    Can you clean the sensor yourself if the automatic removal does not remove dust. Or do you need to send it to Olympus for cleaning like you do the other 5 axis bodies?
     
  5. dhazeghi

    dhazeghi Mu-43 Hall of Famer

    Aug 6, 2010
    San Jose, CA
    Dara
    Like the 5-axis IS bodies, the sensor is essential loose when the camera is off. That means that pressing it with a sensor swab can throw the system out of alignment, or even potentially damage it. In short, you're not supposed to clean it yourself. You do get one free sensor cleaning by Olympus during the camera's warranty period.
     
    • Like Like x 1
  6. gugarci

    gugarci Mu-43 Veteran

    304
    Jul 8, 2012
    Lyndhurst, NJ
    Bill
    Thanks. I was hoping you could at least clean this one your self.
     
  7. iansmith

    iansmith Mu-43 Regular

    30
    Mar 19, 2014
    Is there anyone on Olympus site about that? Just moving the camera around bounces the sensor a lot harder than a light touch with a swab or lens pen type cleaner would. Not to mention how much it got jostled during shipping.