1. Reminder: Please use our affiliate links to get to your favorite stores for holiday shopping!

returned my Sigma 19mm f/2.8 lens....

Discussion in 'Native Lenses' started by asaulo1, May 25, 2012.

  1. asaulo1

    asaulo1 Mu-43 Veteran

    294
    Feb 21, 2012
    I really tried to like this lens.... but the start up lag really grinded on me... On occasion, I would think that there is something wrong with my EM5 but even on my EPL1, it did the same thing. Just for those that don't know about it, when you have this lens on your camera, it would take 2-3 secs to start and even waking it up from sleep would take about the same time.... I tried to live with it at first but just couldn't after missing some shot opportunities... Anyway, off it goes back to amazon. sigh....
     
  2. luca pascotto

    luca pascotto New to Mu-43

    1
    May 26, 2012
    Yes, i have similar problem with the 30 mm - when I insert in the body I got a message :" plas check the status of a lens". - no way to make it work
     
  3. asaulo1

    asaulo1 Mu-43 Veteran

    294
    Feb 21, 2012
    on the OMD? or which camera body?
     
  4. rjay

    rjay New to Mu-43

    6
    May 18, 2012
    Sigma 19/2.8

    I recently got the new Sigma 19/2.8 for my OMD. I think the lens is great: fast and accurate focus, sharp across the frame and quiet (unlike my old 20/1.7).

    And to top it off, it's relatively inexpensive. For me, it's a keeper.
     
  5. S38

    S38 Mu-43 Regular

    58
    Jul 2, 2010
    renton
    I've been mightily frustrated with this lens! My copy would never focus where I wanted it. I can't tell you how many great shots it has "ruined"!! Just did a test, took six shots with the Sigma and six shots with the Pana 20mm, focused on the same object. The Sigma missed all six times while the Pana locked it all six times...I definitely like the rendering of the Sigma better, but it's going back!
     
  6. jim_khoo

    jim_khoo Mu-43 All-Pro

    Apr 9, 2010
    Kuala Lumpur
    Looks like Sigma has production quality issue with this lens. Mine works fine.
     
  7. asaulo1

    asaulo1 Mu-43 Veteran

    294
    Feb 21, 2012
    Its been a common complaint for sigma. Even for their canon mount, it's hit or miss for a good copy but when you do get a good copy, it's pretty good.

    Sent from my iPhone using Mu-43 App
     
  8. brutto

    brutto Mu-43 Veteran

    221
    Feb 17, 2011
    I got exactly the same thing with mine after a few shots and returned it for a refund.
     
  9. Monza76

    Monza76 Mu-43 Regular

    98
    Mar 22, 2012
    I had a Sigma 24-135mm lens in Pentax mount. Everyone else was returning their's, numerous errors, menus shutting off etc. I had it happen once and found that all I needed to do was clean the electronic contacts on the lens mount and it worked fine. Could it be something similar here? I ended up selling the lens (it was much bigger and heavier than the Pentax FA 28-105mm), and I warned the friend who bought it, he hasn't had a problem.

    Would I buy Sigma again, probably not, the quality control seems to still be an issue. Stories like these do not inspire confidence.
     
  10. kevwilfoto

    kevwilfoto Mu-43 Veteran

    294
    Sep 23, 2011
    Colorado
    Ditto here. Yes, the start-up is very, very slow. Luckily it hasn't been an issue for me.
     
  11. CUB

    CUB Mu-43 Veteran

    275
    Apr 19, 2012

    Just like every lens Sigma ever made. :wink:
     
  12. jim_khoo

    jim_khoo Mu-43 All-Pro

    Apr 9, 2010
    Kuala Lumpur
    don't they listen?
     
  13. ageha

    ageha Mu-43 Regular

    64
    Jun 14, 2011
    Why? They sell anyway. ;-)
     
  14. CUB

    CUB Mu-43 Veteran

    275
    Apr 19, 2012

    They have been in business a very long time and for as long as I can remember they have made lenses of variable quality.

    They are still in business. People keep buying their lenses. So why listen?
     
  15. ean10775

    ean10775 Mu-43 All-Pro

    Jan 31, 2011
    Cleveland, Ohio
    Eric
    I find this interesting because one of my complaints about the Pany 20 and why I am returning it is that it never focuses on what I want it to.
     
  16. broncophil

    broncophil Mu-43 Veteran

    243
    May 23, 2010
    bh shows discontinued?
     
  17. zapatista

    zapatista Mu-43 Top Veteran

    668
    Mar 19, 2012
    Denver, Colorado, USA
    Mike
    I've taken 300+ shots with the 19mm on NEX 5N/7 bodies and have gotten great shots and fast auto focus (we are talking the Nex here). As far as using the 19mm on an m43 (using GH2/E-PM1)...well I can't really comment. 20mm f1.7 still focuses plenty fast coming from the Nex. I just wish Panasonic and Olympus would introduce focus peaking for manual focusing like Sony Ricoh/Pentax have.