Really Strange Music Playback Behaviour...

Discussion in 'The Watering Hole' started by PeeBee, Mar 7, 2016.

  1. PeeBee

    PeeBee Mu-43 Top Veteran

    665
    Sep 17, 2012
    UK
    Hi All,

    Last week I bought 3 albums from iTunes. When I play one of the tracks on my iPod Touch (6th Gen) via bluetooth to my portable speaker, and it's volume is under 50%, the timeline progresses, but there is no audio. It's a 6 minute track, so I get a 6 minute break in playback. If I press the volume (speaker or iPod) either up or down, the audio will kick in and it plays to the end. If the volume is set to over 50%, it plays from the start. So far I've deleted the file and downloaded it again, converted it to mp3 via iTunes, converted to mp3 via an external encoder (and tried various bit rates), burned it to cd and ripped it back as an mp3, and now I've even purchased it again through Amazon, and it still behaves the same way.

    I've deleted the bluetooth pairing and re-paired. I've reset the ipod twice, once I reinstalled from a backup and now I've set it up again from scratch. I've saved the file to a different playlist, I've even reinstalled iTunes. If I link the iPod and speaker via cable, its fine. If I play the same track via the same iPod to a different bluetooth device, it's fine. If I play the track through a different iPod (Nano 7th Gen) to the same bluetooth speaker, its fine. It's only when I play that track to that speaker via that iPod's bluetooth, and the volume is under 50%.

    TBH, the track isn't that important to me, but the fact that this is beating me is driving me nuts. I'm just wondering if anyone has any suggestions please?
     
  2. ex machina

    ex machina Mu-43 Top Veteran

    806
    Jan 3, 2014
    Northern Virgnia
    Sounds very voodoo. In iTunes you can adjust the volume of a given track if you select the track and then CMD-i or choose File > Get Info and then select the Options tab -- maybe try boosting that value?
     
    • Appreciate Appreciate x 1
  3. PeeBee

    PeeBee Mu-43 Top Veteran

    665
    Sep 17, 2012
    UK
    I haven't tried boosting the volume, but I've checked that the default volume is set the same as the other tracks in the album. When the track plays it is at the same volume as the other tracks. I'll try boosting it just to see what happens, thanks.
     
  4. ex machina

    ex machina Mu-43 Top Veteran

    806
    Jan 3, 2014
    Northern Virgnia
    The only other thing I can think of trying that you haven't already is to burn the album to CD, then re-import it, which will re-encode the file, and see what happens. Maybe even re-encode at a different bitrate or format. Heck, change the numbering scheme and file name since we're talking voodoo, here. ;)
     
  5. PeeBee

    PeeBee Mu-43 Top Veteran

    665
    Sep 17, 2012
    UK
    Thanks again. Already tried all of the above but joy. I can't use the PC right now so I'll try the default volume when I can get to it. Yesterday I had the same problem with 4 tracks from one of the other new albums, but that has been resolved by the ipod reset, now its just the one track as far as I know.
     
  6. PeeBee

    PeeBee Mu-43 Top Veteran

    665
    Sep 17, 2012
    UK
    OK, progress thanks to ex machina (huge thanks!). On the file options in iTunes, I've taken the volume up one notch and the start position forwards by a few seconds. The track now plays, but the start needs winding back a bit. I'll play with it tomorrow to see if I can fine tune it a little. The wife tells me it's too late to be playing metal :rolleyes::2thumbs:
     
    • Like Like x 1
  7. PeeBee

    PeeBee Mu-43 Top Veteran

    665
    Sep 17, 2012
    UK
    Further investigation and it seems the problem is with the track start position, not the volume (I've set the volume gain back to 0). It now plays fine in a play list, where the start position in iTunes has an effect (starting at 0:03), but if I manually skip to the start of the track, it starts at 0:00 - and no audio is put out. I'll fire up Audacity when I get home from work and trim the start off the track. Its as though something at the start of the track is telling it to mute, but only one bluetooth device is affected. Definitely Voodoo!
     
  8. PeeBee

    PeeBee Mu-43 Top Veteran

    665
    Sep 17, 2012
    UK
    Clipped 1/10th sec of silence off the start of the track in Audacity - problem solved! :dance::dance4::dance2:
     
    • Winner Winner x 1
  9. ex machina

    ex machina Mu-43 Top Veteran

    806
    Jan 3, 2014
    Northern Virgnia
    Glad you got it sorted -- even if it's complete and total voodoo!
     
    • Appreciate Appreciate x 1