Problem with Panasonic DMW-LVF2E

Discussion in 'Help and Feedback' started by jas101, Mar 26, 2013.

  1. jas101

    jas101 New to Mu-43

    1
    Mar 26, 2013
    Hi everybody!

    I just have bought the viewfinder (LVF2) for the Panasonic GX1.

    I attached the viewfinder to the camera and when I see through it I see this:

    LVF2 Colour 1.

    LVF2 Colour 2.

    LVF2 Colour 3.

    I can't see normal view I see in the LCD panel.
    I see the image decolorated in red tones.


    I don't know if I'm doing something wrong or if the viewfinder is not OK or if the camera is not OK.

    Any suggestions?

    Please help.


    Thanks in advance.
     
  2. GFFPhoto

    GFFPhoto Mu-43 All-Pro

    Feb 24, 2013
    Exchange it. It shouldn't look like that, it should look like the rear display.
     
  3. davidzvi

    davidzvi Mu-43 All-Pro

    Aug 12, 2012
    Outside Boston MA
    David
    Having a similar issue I think, through viewfinder is like 2-3 spots over exposed and on the grainy side. I got it to look right for about a minute cycling through the shooting modes. But then it went a overexposed again.

    Also it goes into a negative look when an image is captured.

    Normal or a bad unit?
     
  4. RoadTraveler

    RoadTraveler Mu-43 All-Pro

    Nov 23, 2012
    I'll be interested to learn what fixes this. I have a few LVF2s on a few bodies and would like to be aware of potential problems.

    Is the viewfinder new?
     
  5. davidzvi

    davidzvi Mu-43 All-Pro

    Aug 12, 2012
    Outside Boston MA
    David
    No, it was KEH EX+. Though on Monday I will be calling to at least question that grade.

    I take it the view through your LVF2 look just like the back LCD?

    Wonder how Jas101 got those pictures of the image though the viewfinder.