Problem with E-M1X and legacy 14-50 PanaLeica

lemalk

New to Mu-43
Joined
May 31, 2011
Messages
4
Hi everyone,
I am having a very strange issue that is driving me nuts (!) and I am hoping someone here may be able to help.

I am a long-time 4/3rds and mu-43rds user. I have used a PanaLeica 14-50 2.8 on an E-P2 and E-M1 mark I with a DMW-MA1 adapter for almost ten years without issue.

I upgraded to a E-M1X very recently and when I went to mount the lens, all I got was a black screen. All my other 4/3 glass (11-22 Oly; 25mm 1.4 PanaLeica, 35mm 3.5 Macro) mount without issue.
I then mounted the 14-50 and adapter back on the E-M1 and all worked fine.
Here’s where it gets strange:
I saw other postings on here where there is an issue with the pin on the adapter not locking correctly - that’s not the case here. I can hear the pin lock, and as soon as it locks, I get a black screen. If I depress the adapter’s release button, I can then see an image, but can’t auto or manual focus.
I cleaned the lens mount with alcohol and it was clean; same with the adapter.
After getting frustrated that I couldn’t use my favorite lens, I figured that maybe another adapter would function so I began searching for another 4/3 -> m4/3 adapter (they have really gone up in price since the last time I checked!).

Lo and behold, got an Olympus MMF-1 this week - as close to mint as possible; and....when I mount it on the E-M1X, I had the exact same issue with the 14-50 lens (all others worked fine). Now I know it’s not the adapter, and it’s not the lens (since it works fine on the E-M1, and it isn’t the camera since it can use all my other legacy glass without issue!

I feel like I am going nuts! Anyone have any insight?
Thank you in advance for your help!
 

mtc

New to Mu-43
Joined
May 29, 2012
Messages
2
Location
San Francisco, CA
Unfortunately, it's a known issue. See https://www.dpreview.com/forums/thread/4202687

The Panasonic Leica 14-50 2.8-3.5 is not supported on the E-M1 II, EM-1X or EM10 III. My guess is that it's not supported on any bodies more recent than the Pen-F. See https://av.jpn.support.panasonic.com/support/global/cs/dsc/connect/FourThirds_lens.html.

I also have the the 14-50 and was looking forward to using it with my E-M1 II. Using a cheap adapter, I also ran into the same "black-screen" problem you ran into. My wife then bought me an official Panasonic 4/3-m4/3 adapter and it didn't work any better. At that point, I looked for and found the above dpreview thread.

At least you've got the E-M1. I might get one too, if only for this old but interesting lens.
 

ashburtononline

Mu-43 Veteran
Joined
Jan 21, 2015
Messages
459
Location
New Zealand
Olympus lenses on Olympus bodies ... Why should a Panasonic lens work ... They share a sensor size but no guarantee lenses work! Use Olympus glass.
 

lemalk

New to Mu-43
Joined
May 31, 2011
Messages
4
What a heartbreak. I realize that that lens and the 25mm 1.4 PanaLeica were the two things anchoring me to m43 and to Olympus cameras for so many years since they worked much better with legacy lenses than Panasonic bodies.

Obviously there are much more important things in the world right now, but this is still a disappointment.

thank you for that thread and official compatibility grid. Still sucks :/


Unfortunately, it's a known issue. See https://www.dpreview.com/forums/thread/4202687

The Panasonic Leica 14-50 2.8-3.5 is not supported on the E-M1 II, EM-1X or EM10 III. My guess is that it's not supported on any bodies more recent than the Pen-F. See https://av.jpn.support.panasonic.com/support/global/cs/dsc/connect/FourThirds_lens.html.

I also have the the 14-50 and was looking forward to using it with my E-M1 II. Using a cheap adapter, I also ran into the same "black-screen" problem you ran into. My wife then bought me an official Panasonic 4/3-m4/3 adapter and it didn't work any better. At that point, I looked for and found the above dpreview thread.

At least you've got the E-M1. I might get one too, if only for this old but interesting lens.
 
Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Mu-43 is a fan site and not associated with Olympus, Panasonic, or other manufacturers mentioned on this site.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Forum GIFs powered by GIPHY: https://giphy.com/
Copyright © Amin Forums, LLC
Top Bottom