Problem with Canon FD adapters

Discussion in 'Adapted Lenses' started by Andrew H, Jul 24, 2011.

  1. Andrew H

    Andrew H New to Mu-43

    Jun 26, 2011
    Hello all

    I have purchased two Canon FD to mu-4/3 adapters on e-Bay from separate vendors. They seem to be quite well made and are identical, with the same markings, so I guess they're from the same factory somewhere in China.

    They both work fine with the 'new' FD lens mount (where the whole lens turned when mounting onto the Canon camera) but both exhibit the same problem when mounting lenses with the original breech-lock FD mount (where the lens was locked onto the camera by turning a ring at the rear of the lens and not the whole lens).

    The problem is that the lens ring does not turn sufficiently when mounting the lens on the adapter - only about half as far as it does when mounting onto the old Canon camera - and doesn't fully enable the lens' aperture mechanism, with the result that although the aperture ring on the lens turns through its full range the aperture itself only stops down to about half way through its range. The main lens I am trying it with is an old, but excellent Canon 50mm f1.4, and looking through the lens after mounting it on the adapter the iris stops closing down after the aperture ring gets to about f6.3, although the aperture ring will continue turning right to f16. Another breech-lock FD I have also shows the same problem.

    I can see what the problem is - on the adapter the thickness of the flange onto which the lens tightens when the lens ring is turned is thicker that the corresponding flange on the Canon camera, and thus the ring tightens after less rotation than on the camera.

    Has anyone else experienced this, and can anyone point me in the right direction to purchase an alternative adapter which does work correctly with the old breech-lock FD mount, please?

  2. Luckypenguin

    Luckypenguin .

    Oct 9, 2010
    Brisbane, Australia
    Real Name:
    My FD adapter (brand unknown) does the same, although it usually makes it to f/8. I prefer the new FD lenses anyway so I have never investigated trying to fix or replace the adapter.
  3. chrism_scotland

    chrism_scotland Mu-43 Veteran

    Jun 1, 2011
    Edinburgh, Scotland
    I've got a Canon 50 FD without the breechlock on the bottom and a 24mm with the breechlock, both seem to work fine on my adaptor, again generic - Pixco branded if that helps.
    • Like Like x 1
  4. photoSmart42

    photoSmart42 Mu-43 Top Veteran

    Feb 12, 2010
    San Diego, CA
    It's a common problem with the cheap adapters. The solution is to sand the top mounting surface of the adapter until you can turn the locking ring more. Use fine grit sandpaper on a very flat surface, and go slowly while regularly checking the fit. Definitely a case of you get what you pay for.
  5. zpuskas

    zpuskas Mu-43 Veteran

    Feb 25, 2011
    Santa Barbara, CA
    I bought an adapter from digibatterycity, NY, (EBay) that was advertised for FD lenses only, but found it works great on my old FL breech lock lens too. Works on all apertures down to f16. Not sure if it would work with FD breech lock lenses.
  6. CarlB

    CarlB Mu-43 Veteran

    Great idea to sand down the mounting surface. If that doesn't work for you, I can recommend fotodiox, which works a charm for my old FD
  7. nuclearboy

    nuclearboy Mu-43 Top Veteran

    Jan 28, 2011
    Ellicott City, MD
    Real Name:
    My fotodiox adapter worked

    I had a breech lock 200mm f2.8 and my adapter (Fotodiox from Amazon) worked fine.
  8. Andrew H

    Andrew H New to Mu-43

    Jun 26, 2011
    Thanks to all who replied to this thread.

    Having mulled over what to do, I figured that as my adapters cost only about GBP20 each (approx US$32) I wouldn't be losing a lot if I messed one up adjusting it and could purchase a replacement from Fotodiox if necessary.

    I'm fortunate to have a small metalworking lathe (another hobby), so I decided to turn down the lens ring instead of sanding it. I took the adapter apart, mounted the lens ring on the faceplate of the lathe and took a few very fine cuts from the mating surface, re-assembling the adapter after each cut and testing it with the breech lock lens, until I had removed sufficient metal to allow the lens to stop down to f16, its smallest aperture.

    I then checked for infinity focus with the lens mounted on the camera, and found that this was obtained at the 10 metres mark on the focusing scale. For a 50mm lens this corresponds to an error in the lens to sensor distance of 0.25mm. I found I had a piece of model makers' plastic sheet of that thickness, so I cut a spacer from it and inserted this between the ring and the body of the adaptor.

    Mission accomplished - I now have a nice example of legacy glass with a maximum aperture of f1.4 which stops down correctly and which I can focus by scale if I need to.

    The picture shows the parts ready for reassembly - the white ring is my plastic spacer. As you can see I have turned down through the plating of the lens ring to expose the brass from which the ring is made, but I guess that won't matter.


    Attached Files:

    • Like Like x 4
  9. madseavets

    madseavets New to Mu-43

    Dec 9, 2011
    Does your Pixco branded adaptor give infinity focus/focus past inifinity? I wondered about getting one as they are a lot cheaper than the ones SRB sells.
  10. mattydix

    mattydix New to Mu-43

    Dec 1, 2011
    No problems with Fotodiox's FD to MFT adapter so far. At first couldn't get the aperture blades to move then realized I was missing a step in the mounting. Not sure how it compares to others but it does what it promises.
  11. carlosfm

    carlosfm Mu-43 Veteran

    Oct 3, 2015
    Lisbon, Portugal
    This is very curious because I ended up doing the same thing. Sort of...
    Fist I bought a no-brand, chinese cheap Canon FD to m4/3 adapter, which is a one piece job.
    Very frustrated that it focused way past infinity, I've bought another, which says "Pixco" on it and is very similar to yours.
    It also focused way past infinity...
    To make it worse, ONE (and only one) lens that I have didn't mount on it, I couldn't rotate the ring.
    I've sanded it and now all my lenses mount easily, as they do on my Canon T90.
    Then I've started mulling over the focusing problem.
    What I did was dismantling the lens ring on the adapter and putting aluminium tape in it.
    By trial and error I've ended up with 3 layers of aluminium tape.
    I've also dismantled the aperture ring on the adapter, cleaned all the thin oil and applied thick(er) STP oil additive.
    The aperture ring on the adapter now works smoooothly, great feel.
    And now ALL my lenses focus spot on at infinity, as they ever did on Canon film cameras and as they should.

    I'm a happy bunny now.