1. Reminder: Please use our affiliate links for holiday shopping!

Problem using adapted lens

Discussion in 'Adapted Lenses' started by turbodieselvw, Jun 29, 2010.

  1. turbodieselvw

    turbodieselvw Mu-43 Veteran

    321
    Jun 29, 2010
    Ottawa
    I have a Panny GF1 and the 14-140 lens and love it. I am, however, having a problem using my old Nikon Al lens with it. I have a Nikon adapter which I bought from eBay and I'm able to focus and fool around with exposure but when I try pressing on the shutter button, I keep getting this message "Please check that lens is attached correctly."
    Has anyone experienced this? How do I go about using my old lens?
    Thanks a million.
     
  2. RonSmith

    RonSmith Mu-43 Top Veteran

    505
    Apr 7, 2010
    Michigan
    In custom menu (page 5), you have turn "Shoot Without Lens" to ON.
     
  3. photoSmart42

    photoSmart42 Mu-43 Top Veteran

    628
    Feb 12, 2010
    San Diego, CA
    That, and you can't use a legacy lens in iA or any other preset mode - you have to be in one of the P, A, S, or M modes.
     
  4. turbodieselvw

    turbodieselvw Mu-43 Veteran

    321
    Jun 29, 2010
    Ottawa
    Fantastic! Thanks for the info! I'm assuming that when switching back to m4/3 lens the "shoot without lens" will have to be turned back to OFF?

    I thought legacy lenses could only be used in A, S or M modes and not P. Anyways, I'll have to fool around with this now that I know what I'm supposed to do.
     
  5. RonSmith

    RonSmith Mu-43 Top Veteran

    505
    Apr 7, 2010
    Michigan
    You can leave SHOOT W/O LENS on all the time. It has no effect on m4/3 lenses.

    You can only use A or M with legacy lenses. The camera cannot set the aperture on the lens, which is necessary with S or P.
     
  6. turbodieselvw

    turbodieselvw Mu-43 Veteran

    321
    Jun 29, 2010
    Ottawa
    DUH! Ron, you're correct; only A or M with legacy lenses. Thanks once again!
     
  7. photoSmart42

    photoSmart42 Mu-43 Top Veteran

    628
    Feb 12, 2010
    San Diego, CA
    I shoot in P and S all the time with my legacy lenses on my GH1. Perhaps it's different on the GF-1. On the GH1 you need to make sure you enable SHOOT W/O LENS in each mode separately.
     
  8. hoggdo c

    hoggdo c Mu-43 Regular

    37
    May 12, 2012
    Huntington Beach, CA - SOCAL
    Wayne
    Different Cameras

    With my Olympus OM-D there is no setting to shoot without a lens, it just does. No only that but it will shoot in every mode, you just have to remember to focus and set the aperture manually.

    It is turning out to be a very versatile camera with great images. :smile: