Please Help, new E-M5 II LCD won't go on?

Discussion in 'Olympus Cameras' started by sgreszcz, Aug 2, 2015.

  1. sgreszcz

    sgreszcz Mu-43 Veteran

    439
    Oct 7, 2012
    Hi there,

    I just got a new E-M5 II camera, and the LCD was working but now after the firmware update (a couple of days later), for some reason it doesn't come on any more. the EVF is working, but I cannot pull up the menu to try and do a factory reset. I've tried to take out the battery (which is fully charged) but it still doesn't work.

    I'm experienced with the original E-M5, E-PM2, E-P5, and other Panasonic mu4/3 cameras, but this is just plain weird.

    As an aside, I also find the camera really laggy when trying to operate it (EVF, etc.)

    Hopefully the LCD isn't broken as I have read bad things about Olympus support...
     
  2. Growltiger

    Growltiger Mu-43 Top Veteran

    652
    Mar 26, 2014
    UK
    Have you pressed the button to the left of the eyepiece?
     
  3. sgreszcz

    sgreszcz Mu-43 Veteran

    439
    Oct 7, 2012
    Do you mean the button that switches on/off the EVF eye detection? (It is actually on the top right deck). I have manually tried switching on the LCD but no luck.

    It is really frustrating too, but I can get the SCP to display in the EVF (and the picture review), but I've only managed to get the main configure menu to show in the EVF once, when I forced a factory reset.

    I still haven't managed to get the LCD to come back on, so I think I will call Olympus support tomorrow.

    I'm very disappointed in this, as I've opened quite a few cameras (including refurbs) but haven't experienced a failure like this before. I will some more digging online.

    On the upside, I love the improved EVF (like my old VF4) and the grip is much better than the old E-M5 (much like my LX100).
     
  4. sgreszcz

    sgreszcz Mu-43 Veteran

    439
    Oct 7, 2012
  5. runner girl

    runner girl Mu-43 Regular

    192
    Nov 26, 2011
    You might try removing the eye cup and cleaning the contacts. I had this issue and that solved it.
     
    • Like Like x 1
  6. sgreszcz

    sgreszcz Mu-43 Veteran

    439
    Oct 7, 2012
    How weird. I'll try that tonight before trying to Return it for a replacement tomorrow...
     
  7. sgreszcz

    sgreszcz Mu-43 Veteran

    439
    Oct 7, 2012
    No luck, didn't work. Will exchange tomorrow :(