Please check the status of the lens _ Message

Joined
Mar 21, 2011
Messages
442
On my Oly 9-18mm I get this message when I press the shutter when at 18mm.
It is working fine at all the other focal length!
I have the latest firmware on both the lens and the camera!
Help
 
Joined
Jan 19, 2018
Messages
303
Location
Columbus, Ohio, US
Real Name
Mark
I JUST had this. It's a broken (or breaking) cable in the lens. Mine wouldn't focus past 14mm but would under. It will get progressively worse and malfunction at shorter and shorter focal lengths. Sorry to be the bearer of bad news.

I think it cost me about $150 total to have it fixed. Do FULLY test the lens when it comes back from repair. I tested the autofocus (as that's what was broken) and it worked fine but months later I figured out that now it won't manual focus. Oh well. That one's on me.
 
Joined
Mar 21, 2011
Messages
442
I JUST had this. It's a broken (or breaking) cable in the lens. Mine wouldn't focus past 14mm but would under. It will get progressively worse and malfunction at shorter and shorter focal lengths. Sorry to be the bearer of bad news.

I think it cost me about $150 total to have it fixed. Do FULLY test the lens when it comes back from repair. I tested the autofocus (as that's what was broken) and it worked fine but months later I figured out that now it won't manual focus. Oh well. That one's on me.
Thanks, I Googled it and it seems to be a recurrent problem!
Yes just like yours anything pas 14mm doesn't work!
How long did it took to have it fixed?
 
Joined
Jan 19, 2018
Messages
303
Location
Columbus, Ohio, US
Real Name
Mark
Mine took a while because they had to wait on parts. It's my understanding it's normally about 2 weeks from the time you drop it into the mail until it's back to you. Mine was gone more than a month and the communication wasn't great. I had to chase them down and with multiple calls to get status and then it showed up at my house (fixed?) the day they told me the parts were arriving.
 

Sammyboy

m43 Pro
Joined
Oct 26, 2010
Messages
1,383
Location
Steeler Country
..... NEVER, NEVER, NEVER collapse this lens and the 14-42 IIR .... this is a common problem caused by putting the lens in the "park" position .....
 

Bushboy

Mu-43 All-Pro
Joined
Apr 22, 2018
Messages
1,066
Location
Aotearoa
Real Name
Charlie
I had this message on my 60 macro. It cost me more to get it fixed, than the lens was worth...
 

Latest posts

Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Mu-43 is a fan site and not associated with Olympus, Panasonic, or other manufacturers mentioned on this site.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Copyright © 2009-2019 Amin Forums, LLC
Top Bottom