PL 45/2.8 Malfunction

Discussion in 'Native Lenses' started by RonSmith, Jul 14, 2013.

  1. RonSmith

    RonSmith Mu-43 Top Veteran

    505
    Apr 7, 2010
    Michigan
    I bought my Pan-Leica 45/2.8 in April 2010, and it has been one of my favorites. Never had a problem with it until today. It worked fine yesterday, but today it wouldn't focus on my GH3. Tried auto focus and manual; nothing. I tried other lenses to make sure it wasn't my GH3, and I tried the 45 on my GF1 without any function. I cleaned the contacts with a soft eraser. Nothing.

    I found the Panasonic Customer Service website and sent an e-mail off describing the problem.

    I then gave it one more try, and,naturally, the lens worked fine. Took a few pictures and focus is spot on.

    Has anyone experienced any similar problems with the 45?
     
  2. vchaney

    vchaney Mu-43 Regular

    33
    Sep 22, 2010
    It could be that the lens release button has been pressed and the contacts weren't lining up or that the contacts are dirty. You can clean them with a pencil eraser. As its focus by wire the connection needs to be good for MF as well as AF
     
  3. Mijo

    Mijo Mu-43 Veteran

    220
    Jan 23, 2012
    San Francisco, CA
    I rarely use my PL 45, as I'm not that fond of the FL. However the last time I used it I noticed that it took a long time to AF on my EM-5, even with the focus set to "limit". The lens seems to hunt more when on the EM-5 than it does on the GX1, I'm not sure if this is specific to my copy of the lens though.
     
  4. derangboy

    derangboy New to Mu-43

    7
    Dec 11, 2010
    near Calgary
    I had the exact same problem with my 45 PL. Wouldn't focus on my GF1 or GX1. Until I phoned Panasonic for repair information. It's worked fine since then (about 10 months). Only now I have a similar problem with my 8mm...