Pixel RW-221 wireless shutter release plug

Discussion in 'Accessories' started by curveshooter, Sep 13, 2014.

  1. curveshooter

    curveshooter Mu-43 Regular

    57
    Nov 29, 2012
    North Carolina
    I purchased this wireless shutter release (link) a year ago. It worked fine at first, but now it's hit or (mostly) miss. The plugs are oriented correctly with the right angle plug going into the camera body and plugs are seated firmly.

    The connection between transmitter and receiver appears to be fine as a half press on the transmitter button focuses the camera.

    Even the receiver button by itself cannot reliably activate the shutter. I think the problem lies with the poorly designed plug that connects to the camera. Has anyone figured out a solution to this besides "keep pressing harder on plug and pray"?

    I might take an exacto knife and dremel to the plug and see if I can improve the connection it makes to the camera.

    What other wireless shutter releases are available for the Panasonic G3?
     
  2. OzRay

    OzRay Mu-43 Legend

    Jan 29, 2010
    South Gippsland, Australia
    Ray, not Oz
    If you don't need to fire the shutter from a great distance (more than say two metres), you'd be better off with a wired shutter release cable, they are reliable and don't need batteries.
     
  3. curveshooter

    curveshooter Mu-43 Regular

    57
    Nov 29, 2012
    North Carolina
    OK, I think I have this problem licked.

    First, I shaved down the plastic housing around the right angle plug so that it sits deeper in the camera socket. That didn't seem to make much, if any, difference. The shutter would activate sometimes if simultaneously pushing both ends of the plug in firmly. And sometimes it wouldn't.

    Next, I took some 220 grit sandpaper and roughed up both plugs a little bit. Cleaned up with isopropyl alcohol, and now it works! Even tried removing both plugs while camera and receiver were on, and reinserted the plugs firmly and it continues to work. I've wirelessly activated the shutter roughly 50 times and it has worked every single time. It functions better than when it was new, and much better than it has in recent months.