Pen - F Hot Shoe problems.

Discussion in 'Olympus Cameras' started by nono, Apr 1, 2016.

  1. nono

    nono New to Mu-43

    Mar 17, 2016
    Hello Everyone,

    I have been looking in on this forum for a few weeks now, and have enjoyed reading your posts and looking at some fantastic shots!

    I have decided to ask for some advice on a couple of issues,
    as they are not related, i shall split them over a couple of posts.

    First of all, i get no response from my New Pen - F hot shoe. The supplied FL - LM3 flash does not fire, and i also tried to fire the FL 600r with no luck.

    I then checked my FL 600r with my OMD - EM1 and it worked perfectly. Does anybody else know of hot shoe problems?

    If it does turn out to be a faulty hot shoe, and not some stupid mistake that i'm making, what's the best way to get something done about it?

    Thanks in advance for any help!!!
  2. b_rubenstein

    b_rubenstein Mu-43 All-Pro

    Mar 20, 2012
    Melbourne, FL
    The flash won't fire if the shutter is set to silent or the flash is disabled. Both can be checked in the Super Control Panel (SCP).
    • Agree Agree x 1
  3. Dogman

    Dogman Mu-43 Regular

    Dec 23, 2012
    I had a similar issue, but found that if I pushed the flash forward a little harder, it worked.
  4. Mister Summar

    Mister Summar Mu-43 Regular

    Aug 31, 2015
    For me it was a settings issue. It would work in iAuto mode but not others. Don't remember exactly which setting.
  5. AV77

    AV77 New to Mu-43

    Oct 9, 2016
    Hi - I'm having precisely the same problem as nono raised. Flash is on full - I'm not using silent shutter - flash has been pushed in as much as possible - have done a full reset - fully charged battery - still nothing working! Please can anyone help?
  6. Growltiger

    Growltiger Mu-43 Top Veteran

    Mar 26, 2014
    Did you switch on the flash?
    Did you try iAuto?
    Is the flash turned on in the settings?
  7. AV77

    AV77 New to Mu-43

    Oct 9, 2016
    Yes flash is on, iauto has been tried, as well as aperture and shutter priority and full manual and flash is enabled everywhere i can see in settings - any setting in particular you think would be good to check?
  8. Growltiger

    Growltiger Mu-43 Top Veteran

    Mar 26, 2014
    No more ideas. Ideally you need to try the flash on a different camera, and try a different flash on that camera.
    Maybe it is time to send them back to Olympus.