1. Reminder: Please use our affiliate links for holiday shopping!

Panny 25mm 1.4 question

Discussion in 'Native Lenses' started by peterpix, Jan 2, 2012.

  1. peterpix

    peterpix Mu-43 Veteran

    234
    Feb 8, 2010
    So. Maine
    Peter Randal
    The "focus" ring on my lens just turns without having any effect on focus? Is this normal? Also when using this lens for video on Olympus, auto focus keeps hunting if the camera is moved all to change composition. Any way to turn off auto focus (but then I'm back to the first queqtion?!
     
  2. juju

    juju Mu-43 Rookie

    21
    Dec 22, 2011
    Philippines
    did you turn on AF + MF in the custom menu? also try disabling continuous AF in video. sorry not familiar with olympus.
     
  3. WoodWorks

    WoodWorks Mu-43 Regular

    180
    Oct 10, 2011
    Ashland, OR USA
    David
    I think the solution to both of your problems might be with your camera settings rather than the lens. In order for the focus ring to work, you have to be in manual focus mode, or as with Panasonic cameras (not sure about Olympus), you have to have AF+MF engaged in your custom settings. This will allow you to use auto-focus and then sharpen/tweak the focus manually when the shutter is half-pressed.

    Focus hunting when shooting video, especially in low light, is all too common with just about all lenses. Some are better than others, but the solution there is again to use manual focus. I don't know which camera you're using, but your manual should provide instructions about how to switch to manual focus.

    Hope that helps.

    David
     
  4. supermaxv

    supermaxv Mu-43 Veteran

    273
    Sep 20, 2011
    This sounds like user error. Which camera body do you have?
     
  5. peterpix

    peterpix Mu-43 Veteran

    234
    Feb 8, 2010
    So. Maine
    Peter Randal
    Comments appreciated. Lens does focus with the ring properly on my GH2, but not with EP3? Clearly there is a setting I am missing on the Olympus but the manual is not much help
     
  6. fdifulco

    fdifulco Mu-43 Veteran

    251
    Nov 28, 2011
    New Orleans, Louisiana
    Frank
    make sure you have all the menus enabled.

    select menu and go down till you see a wrench, select and then scroll down to menu and select. turn on both menus and then select ok.

    hit menu and then 4th one down that looks like two cog wheels select. the first option on the cog menu is A, AF Mode. select still picture and make sure you have either S-AF+MF or C-AF+MF. enable one of th AF+MF modes.

    after you select still now pick movie, same drill and pick how you want your focus to work.

    you also want to make sure you have the super control panel enabled, which you can access anytime by pressing the ok button.

    hope this helps
     
  7. peterpix

    peterpix Mu-43 Veteran

    234
    Feb 8, 2010
    So. Maine
    Peter Randal
    Perfect! Many thanks, fdifulco!