Panasonic lens on Olympus body and CA

Discussion in 'Native Lenses' started by CiaranMc, Aug 14, 2012.

  1. CiaranMc

    CiaranMc Mu-43 Rookie

    Jul 8, 2012

    I'm noticing a lot of purple CA when I shoot with a Panasonic 20mm on my E-PM1. Is there any way of correcting for this automatically?

    My workflow is iPhoto/Aperture, if I shoot in RAW will the software be able to correct the CA from the embedded profiles?

  2. Haris

    Haris Mu-43 Rookie

    Apr 16, 2011
    CA correction

    The most RAW software will be able to correct it.

  3. dhazeghi

    dhazeghi Mu-43 Hall of Famer

    Aug 6, 2010
    San Jose, CA
    Real Name:
    Not in the camera.

    There are no embedded CA profiles in the RAW files (Olympus doesn't record CA information). IIRC Aperture doesn't do automatic CA correction.

    Lightroom does do it (automatically correct CA), as of version 4.1.

  4. CiaranMc

    CiaranMc Mu-43 Rookie

    Jul 8, 2012
    Oh, so Lightroom corrects for it even without the profile info?

    I wonder if Olympus future firmware updates will start doing this for Panasonic lenses

  5. danska

    danska Mu-43 Top Veteran

    May 21, 2012
    Portland, OR
    Real Name:
    It's not just Panasonic lenses, their lenses aren't corrected either.
  6. addieleman

    addieleman Mu-43 All-Pro

    Aug 5, 2010
    The Netherlands
    Real Name:
    Yes, it does so automatically for CA (yellow/blue or green/magenta fringes) without the need for lens profiles; I've even used it successfully for scanned slides. Purple fringing around highlights has to be done manually, is also independent of lens profiles and is incorporated in V4.1.