Panasonic 7-14 - purple spots?

Discussion in 'Native Lenses' started by bobby_t1, Oct 13, 2012.

  1. bobby_t1

    bobby_t1 Mu-43 Regular

    60
    Aug 22, 2012
    I traveled overseas for a few weeks with a brand new Panasonic 7-14 on my OM-D. Several times when shooting into direct light, I'm seeing purple spots appear. Is this normal? I've never had this occur with any of my lenses (even UWA) on my D700 or D7000 in the past.

    This is converted to JPG from RAW in lightroom. Look above center to see the purple spots from the bright windows everywhere:

    [​IMG]
     
  2. tk17alex09

    tk17alex09 New to Mu-43

    1
    Mar 6, 2012
    Sheffield, U.K.
  3. jnewell

    jnewell Mu-43 All-Pro

    Jun 23, 2011
    Boston, MA
    If you take a picture with an UWA and have a strong light source in or just outside the frame, you should not be surprised by these results. I'm shocked you haven't noticed it on your DSLRs, especially using UWA lenses.
     
  4. bobby_t1

    bobby_t1 Mu-43 Regular

    60
    Aug 22, 2012
  5. jnewell

    jnewell Mu-43 All-Pro

    Jun 23, 2011
    Boston, MA
    I've been reading that thread since the beginning. As I just posted in that thread, you're not talking about ordinary veiling flare nor ordinary CA, right?
     
  6. bobby_t1

    bobby_t1 Mu-43 Regular

    60
    Aug 22, 2012
    Correct.
     
  7. rssarma

    rssarma Mu-43 Regular

    36
    Apr 1, 2010
    NYC
    I've had similar issues with this lens and correcting it isn't really feasible. I hastily sold my Sigma 12-24mm lens that I used on my D700 and although I like the Pana, I find it completely unsuitable for night time shots. It's such a pity since I really like the size and portability of this lens.