panasonic 14-140 with GH2

Discussion in 'Native Lenses' started by azgh2, Jul 31, 2011.

  1. azgh2

    azgh2 New to Mu-43

    Jul 31, 2011
    I just got Lumix GH2 with 14-140 lens and wondering about strange sound (mechanical sound) coming from the lens when I turn on and off the camera. Also strange mechnical sound is louder when I turn on the camera than turn off.

    Tried with O.I.S switch off but it did not make any difference.

    Is this normal operation for this lens or something wrong with it?

    thank you for your help
  2. Luckypenguin

    Luckypenguin .

    Oct 9, 2010
    Brisbane, Australia
    Real Name:
    I think the sound from the lens when turning the camera on and off is to do with the O.I.S. system. The lens will also reset to infinity focus when turned off. Mine constantly makes a faint sound during operation as well and rattles quite significantly when turned off. My Panaleica 14-50mm O.I.S. (4/3) lens does the same. Having come from using Canon lenses which only make a sound while the Image Stabilizer is working, the various sounds from the Panny lenses are a bit off-putting at first but I accept them as being normal now.
    • Like Like x 1
  3. azgh2

    azgh2 New to Mu-43

    Jul 31, 2011
    This is new to me and I was kinda worried about it.

    thank you for your comment.
  4. carpandean

    carpandean Mu-43 Top Veteran

    Oct 29, 2010
    Western NY
    Isn't there a free-floating element that gets aligned when the lens is powered up? As LP said, I believe that it has to do with the O.I.S. system. The same thing happens with the 14-45mm and PL 45mm, so that would make sense.