1. Reminder: Please use our affiliate links for holiday shopping!

OMD or shutter release? Problems with it not working

Discussion in 'Olympus Cameras' started by gardengirl13, Apr 10, 2014.

  1. gardengirl13

    gardengirl13 Mu-43 Veteran

    200
    Jun 26, 2012
    US
    So I bought the shutter release maybe 18 months ago or so. The battery was supposed to be good for 30 hours and I only got 2.5 out of it. I emailed the company to see if they would send me a new one and they basically said no way. I kept the battery out of the release except when I was using it. So it wasn't that. Well lucky for me I didn't like the digital part of it and I could still use it as a manual release. But last night, using it for the first time in about 9 months due to other things going on, it didn't work at all. When I held the button it would open the shutter, when I let go it would close. But I couldn't get it to lock open. When I did it it would open, then as soon as it was locked it would close. Then when I went to press it to unlock it it opened then closed when I released it. Is there a problem with it, with the camera? Or am I missing something as simple as a setting on the camera with AF or something? Now when I use bulb in the dark I have it on MF not any of the AF modes. So I don't think that could be it? But maybe I'm wrong? When I press it it's not trying to focus or anything like that. When I used it the last time I can't remember if the button came up slightly when I locked it. Or pressed in when I went to release. In my feeble memory I don't think it did. I'm so hoping this is just this crappy release and not my camera!


    Any ideas?
     
  2. Ross the fiddler

    Ross the fiddler Mu-43 Hall of Famer

    Could you provide a photo of it? On some of the remote cable releases with an intervalometer it might have a slide with the button & by pressing down & sliding forward it can lock & then there should be a release button for Bulb shooting. A photo or link to the model you are using would help us to give you some correct advice.
     
  3. gardengirl13

    gardengirl13 Mu-43 Veteran

    200
    Jun 26, 2012
    US
    it's the aputure AP-TR3L

    http://www.amazon.com/Aputure-Contr...e=UTF8&qid=1397148815&sr=1-1&keywords=ap-tr3l

    it's worked for 18 months without a hiccup until I tried to do a star trails photo last night. Not sure why something isn't working right. As I said I'm using it manually not with the battery, so it's working as a straight plain shutter release, with just press the button and release or press it slide and lock it. I'm not doing anything different from the last time I've used it.

    I've been trying to remember if the button came up slightly after it was locked and now I just can't remember at all. I would just get the olympus too expensive release but I don't want to spend another $40 to find out it's the camera.
     
  4. Ron Evers

    Ron Evers Mu-43 Regular

    First thing I would do is replace the battery(s). I know my wired remote does not work in manual without the two AAAs.

    Also, if you are like me, you need to review the manual that came with the remote to freshen yourself with proper operation.