OMD hangs/freezes - ones in a while

Discussion in 'Olympus Cameras' started by maflynn, May 11, 2012.

  1. maflynn

    maflynn Mu-43 Regular

    44
    May 7, 2012
    I've noticed that when my OMD goes into "sleep" mode, on rare occasions it does not wake up. I pull the battery to rectify the problem.

    I've been playing with different configurations it seems mostly related when I have Live View turned off and the EVF doesn't turn on.

    Anyone notice this on theirs. In running tests it seems to occur when the camera is hanging around my neck, that is I cannot recreate this issue with the camera sitting on my desk.

    I wonder if it could also be connected to my lens, it only has occurred when the 20mm lens is attached and not the kit lens.

    I think its a firmware bug only because of the intermittent nature and how it does not affect any other function of camera.
     
  2. thearne3

    thearne3 Mu-43 Top Veteran

    807
    Jan 28, 2010
    Redding, CT USA
    Strange...

    What's your Auto Power Off setting?

    Sent from my iPhone using Mu-43 App
     
  3. Ned

    Ned Mu-43 Legend

    Jul 18, 2010
    Alberta, Canada
    I've heard of this from others as well. Any testing you can do to find the most probably cause would really help a lot of people. You mentioned the 20mm... somebody else thought it might be connected to his Leica 25mm f/1.4 Summilux. You mentioned being in EVF mode with Live View off... have you maybe tried attaching a VF-2 or VF-3 viewfinder?

    I really hope this issue can be resolved by firmware update down the road! It might be a good idea to call the Olympus Repair Center in your area and see what they have to say.
     
  4. maflynn

    maflynn Mu-43 Regular

    44
    May 7, 2012
    Info off - 10 seconds
    Backlit LCD 8 seconds
    Sleep 1 min

    btw, when this occurs, turning the camera off does not do a thing

    I'm heading on vacation next week so I want to avoid any issues if at all possible. I always pack a second camera but its a P&S which works well enough but its no OMD ;)

    So I've been unable to reproduce this issue while the camera is on my desk, but having it hang on my neck and letting it sit there for a period of time I did recreate the issue.

    Here's what I have so far
    1. Live view off with 20mm lens with camera on my neck. Problem can occur.
    2. Live view off with 12-50mm lens with camera on my neck. Problem hasn't occurred (yet)

    I'm going to add the 20mm lens and turn live view on and see if I can get it to hang. I can't spend a ton of time on this, but so far its only happening with the 20mm lens.
     
  5. gsciorio

    gsciorio Mu-43 Top Veteran

    636
    Dec 29, 2011
    Miami, FL
    Mine locked up yesterday. Usually my Pen locks up after a while with the Eye-Fi Card but the OMD never has yet it did. Difference was I was shooting with a Sandisk Extreme Pro card.

    Strange.

    I wonder if the OMD locks up with the grip and two batteries does that mean you have to take out the batteries and the grip then put it all back together to work? That would be a real pain if you're shooting.
     
  6. williamthorpe271

    williamthorpe271 Mu-43 Rookie

    12
    Jun 21, 2010
    Hi, there are a few people reporting this issue over on DPR forum. i have this error myself and have only noticed the lockups with the panasonic 20mm attached when trying to resume from sleep mode, the power down function works normally. this lockup occurs randomly and regardless of the grip being attached. i have notified olympus tech support via email and would suggest anyone with this issue do the same so they can do something about it. regards.
     
  7. maflynn

    maflynn Mu-43 Regular

    44
    May 7, 2012
    So far my lock ups have been all while it hung around my neck unused.

    I agree that dealing with the grip could significantly increase the frustration level. As it stands, the grip I ordered has yet to come in so I'll not be using one :(

    Given the intermittent nature that I'm seeing I'm leaning towards an issue with the firmware as opposed to a defective camera. If it started locking up while shooting then that would alter my opinion. :(
     
  8. maflynn

    maflynn Mu-43 Regular

    44
    May 7, 2012
    I checked to see if the panny lens needed a firmware update but my 20mm is at 1.1 and appears to be current.

    Did you have live view on? So far I've not been able to replicate the problem with live view engaged.

    For my trip, I'll be turning the camera off when ever I'm not shooting. I hate to do that, my other option is to disable the sleep but I don't want to suck the life out of the battery especially since I'm unable to buy a second battery at the moment.
     
  9. Ned

    Ned Mu-43 Legend

    Jul 18, 2010
    Alberta, Canada
    I think what I would do if it were me (bear in mind that I'm still using PENs and don't have an OM-D yet), would be to disable sleep mode and become conscientious about manually turning off the camera after each shooting session. It's probably a good habit to get into anyways, and will probably save you on battery power more than always letting the camera go to sleep on its own.
     
  10. williamthorpe271

    williamthorpe271 Mu-43 Rookie

    12
    Jun 21, 2010
    Hi, yes live view was on. camera and body have latest firmware. first noticed this as you did whilst camera around neck, when i got home i tried resuming from sleep while camera on desk, most of the time it did resume with a half press of shutter button but occasionaly it would not. i think it would be a good idea to keep it switched off as having to remove grip to get to battery is annoying. lets hope they find a fix for it.
     
  11. williamthorpe271

    williamthorpe271 Mu-43 Rookie

    12
    Jun 21, 2010
    unfortunately we only have 1,3,and 5 min options. :wink:
     
  12. BobW

    BobW New to Mu-43

    2
    Apr 30, 2012
    Mine has locked up a couple of times. I do not have the Pany 20mm. It seems like mine has locked up when viewing pictures. I have firmware 1.0.

    Bob W
     
  13. cmpatti

    cmpatti Mu-43 Veteran

    263
    May 8, 2011
    Berkeley, CA
    I had this same problem and ultimately had to return the camera for service. Like you, I first noticed it with the Panasonic 20mm mounted. It then happened with the Panasonic 7-14mm. In a day of shooting the camera shut down perhaps 10 times. Eventually, I noticed it happening even with the 12-42mm Olympus kit lens. A couple of days ago the camera died and couldn't be revived even by replacing the battery. Olympus service (which has been very responsive, by the way), had me send the camera back for a replacement. I suspect that it may be a battery problem and that there never was a connection to the lens that was mounted, but who knows?
     
  14. b_rubenstein

    b_rubenstein Mu-43 All-Pro

    Mar 20, 2012
    Melbourne, FL
    Twice, with only the 20/1.7, the camera would not wake from sleep mode. Never happened with the 25/1.4 or 14/2.5 and never with an Olympus lens.
     
  15. Ned

    Ned Mu-43 Legend

    Jul 18, 2010
    Alberta, Canada
    Oh, carpy...
     
  16. AlanU

    AlanU Mu-43 Veteran

    484
    May 2, 2012
    My E-m5 froze on me once after if went into sleep mode. I had the PL25 f/1.4 on at the time.

    The only way to reset was to pull the battery out.

    I hope they fix this odd problem. My Canon dslr's have never froze like this. I'm confident it'll get fixed with some firmware fix.
     
  17. st3v4nt

    st3v4nt Mu-43 Veteran

    317
    May 26, 2011
    Jakarta, Indonesia
    I still trying to find what froze and erratic behavior with Panny 20 everyone talking about, also the banding. Still haven't find it. Try every possible configuration, let it sleep for a while, with simple touch the camera always wake up. Shoot under fluorescent lighting and low light, I even crank up the ISO to 10.000 and do the 9 fps. Yet I have not yet meet the erratic behavior. Will try the hang in neck configuration as soon as my battery recharged.

    My OM-D firmware version is 1.1
    My 20 mm Panny lens version is 1.1
     
  18. c_henry

    c_henry Mu-43 Regular

    65
    May 12, 2012
    Mine locked up yesterday. Had just taken a couple of pics and was reviewing them when it locked up. None of the buttons worked and when I turned it off the picture I was reviewing remained on the screen. Took the battery out in the end.

    Had the 45mm f1.8 attached at the time.

    - Colin
     
  19. jdp

    jdp Mu-43 Rookie

    13
    May 12, 2012
    Happened to me yesterday. With the 12-50mm attached and the camera turned on I put it into my camera bag. When I took it out a few minutes later it was dead. Had to take the battery out and put it back in before it would turn it back on. Latest firmware is installed.
     
  20. dom-pa

    dom-pa New to Mu-43

    1
    May 26, 2012
    It happened also to me but only with the pana 20 mm when trying to resume from sleep mode. Last firmware installed.
    Hope Oly finds something