OMD EM5 - Corrupt raw files?

Discussion in 'Olympus Cameras' started by ojuice1, Jun 2, 2013.

  1. ojuice1

    ojuice1 Mu-43 Rookie

    20
    May 28, 2013
    So i just got my OMD EM5 and took about 100 shots. Out of the 100 shots 4-5 raw files were corrupted. Has anyone run into that issue? Is it possibly just my SD card?
     
  2. dhazeghi

    dhazeghi Mu-43 Hall of Famer

    Aug 6, 2010
    San Jose, CA
    Dara
    The card is a likely possibility. The other is the card reader/transfer software. Can you display the images in the camera?
     
  3. entropicremnants

    entropicremnants Mu-43 All-Pro

    Jul 16, 2012
    John Griggs
    What means "corrupted"? Did the files transfer and then were unreadable, or did they not transfer in the first place? Which transfer method did you use and what software told you they were corrupted?

    More information, lol!

    I had and E-M5 and did over 7000 shots in RAW and never had this problem. I used class 10 cards from major manufacturers (Sandisk mostly) and I did my transfers managed by lightroom by plugging the card into the card reader -- I never read them viea the USB cable.

    Also, make sure you reformat the card IN THE CAMERA every time you dump it. Never format the card in the computer. For some reason this causes problems. If you have never formatted the card in the camera, definitely do that.
     
  4. christofp

    christofp Mu-43 Regular

    138
    Jul 21, 2012
    Your SD card?

    I use a Sandisk with 95MB/s which should be quite demanding for the OM-D. Had about 30,000 RAW files on two sd-cards and never any issue.

    I format from time to time, but mostly delete in camera or in windows explorer.

    • Maybe the SD card is not OK
    • or OM-D and SD
    • or PC and SD
    don't work well with each other.

    Which SD do you use? Did you make a mass-copy-test from PC to SD and back?
     
  5. ojuice1

    ojuice1 Mu-43 Rookie

    20
    May 28, 2013
    I can view the images on my camera, but when I bring them into Lightroom, I can see the image. The issue is that it gives me an error saying "there was an error working with the photo".

    I am using a "microcenter" class 10 card. Could be janky. I'll try to use a major manufacturer SD card and format it in the camera.
     
  6. ojuice1

    ojuice1 Mu-43 Rookie

    20
    May 28, 2013
    I use the same method...managing by lightroom by inserting the card into a card reader.
     
  7. FrayAdjacent

    FrayAdjacent Mu-43 Regular

    183
    Dec 5, 2012
    Austin, TX
    M@
    The speed of your SD card won't stress the camera - it is only the limit of how fast it can be written to. It can't force the device its in to write that fast.
     
  8. digitaldan1

    digitaldan1 Mu-43 Regular

    78
    Mar 22, 2010
    I've been having some issues with my E-M5 files and photoshop too. I find that the same files that photoshop has problems with do seem fine when I use Olympus Viewer 2. I'm using CS5, so that may be part of the problem.
     
  9. orchard county

    orchard county Mu-43 Regular

    68
    Apr 11, 2013
    ireland
    Hi,just reading through the site and seen your post,i am having the same problem and tried everything ?(i thought)reinstalled software etc,etc,etc,now i have just fired off 13 raw shots at home and put them on the computer(macbook) via the camera/usb and lo and behold every file open in camera raw 7.4&cs6,so thought i might as well try LR 4.4 and positive result again.
    i hope this is it sorted,will try other cards tomorrow when i have time---hope this may have helped you as this was the one way i never even considered as i always used a card reader
    regards orchard
     
  10. b_rubenstein

    b_rubenstein Mu-43 All-Pro

    Mar 20, 2012
    Melbourne, FL
    There is a small embedded JPG in the RAW file, and that's what you're seeing. There is no visible image until a RAW file is converted into a JPG.
     
  11. MMBrown

    MMBrown New to Mu-43

    7
    Dec 28, 2012
    I'm occasionally getting the same thing with my E-P3. Just the occasional file. Happened to me this morning - took about 50 raw shots, 1 could not be imported as Lightroom says it's corrupt. The preview for the file shows up correctly in Lightroom (I presume it's showing the JPEG sidecar file).

    Photoshop CS6 also can't open it.

    Olympus Viewer 3 *can* open it just fine; unfortunately I don't have a clue how to use that program - I really want it in Lightroom...and as a RAW file, not as a jpeg exported from Olympus Viewer, which may be the scenario I eventually have to embrace. :frown:
     
  12. arch stanton

    arch stanton Mu-43 Veteran

    414
    Feb 25, 2012
    London
    Malc
    I've seen this several times with my e-pl3 and lightroom, maybe one in a thousand shots or so.

    Lightroom says the file is corrupt but the preview is fine.

    I've not tried reloading in Oly viewer but will do so next time it happens, would be great to be able to rescue the images. Thankfully it's not happened to a 'keeper' yet!

    Oh, genuine Sandisk class 10 card always formatted in the camera.

    Edit - also thanks to digitaldan for the viewer tip!
     
  13. WasOM3user

    WasOM3user Mu-43 Veteran

    458
    Oct 20, 2012
    Lancashire, UK
    Paul
    I use the Oly viewer to download Raw and JPEG from the camera as that, very nicely, creates a dated folder in the specified directory to put the files into and then import the files from there into LR.

    With sandisk 95mb cards it's not much slower than a USB2 based card reader
     
  14. mdruziak

    mdruziak New to Mu-43

    4
    Jun 6, 2013
    I've had this happen with various Canon bodies over the years. Try to re-copy the image file from your card. Also try to view the image on the card using something like the Picasa photo viewer and see if it is corrupt on the card.

    In all cases for me, a simple re-copy of the corrupt images from the card solved the problem.
     
  15. Iansky

    Iansky Mu-43 All-Pro

    Dec 26, 2009
    The Cotswolds, UK
    OV3

    Try downloading Olympus Viewer 3 from the Olympus site, it is free and a great editor for Olympus files.

    I have abandoned Lightoom and now use OV3 exclusively for batch editing & outputting OMD Raw files as 16bit Tiffs (large files 95mb), I then add borders and crop in PS brfore saving as 8 bit.

    Well worth it as the results are better than lightroom!
     
  16. ojuice1

    ojuice1 Mu-43 Rookie

    20
    May 28, 2013
    Thanks! From doing some reading on the web and other forums...it does look like the Olympus Viewer is the way to go. Seems like that is the go to program that doesn't have any issues.
     
  17. MMBrown

    MMBrown New to Mu-43

    7
    Dec 28, 2012
    Thanks for the suggestion. Unfortunately, it doesn't seem to work in this case. :frown:

    Since I'm able to open the file in Olympus Viewer, is there anyway I can re-save it as RAW through that program? All I can find is an option to export it as a jpeg, tiff, etc. I'm wondering if re-saving it as RAW would then give me a new RAW file to try opening with LR.
     
  18. Wairoakid

    Wairoakid New to Mu-43

    9
    Oct 3, 2012
    Using Olympus Viewer 3 you can make a copy so if you can see it
    From the Browser view of the folder the file is in -right click on thumbnail- it should have RAW in the top right of the thumbnail- and select Save copies

    Makes a copy of the RAW file
     
  19. MMBrown

    MMBrown New to Mu-43

    7
    Dec 28, 2012
    Awesome, that's exactly what I was looking for. Unfortunately, LR still couldn't open my saved copy either. Guess I'll just have to export it and use it as a jpeg or tiff.

    Interestingly, it doesn't have RAW in the top right of the thumbnail - it has a "stack" and a number 2. Hovering over the image describes it as "Drive: Sequential Shooting (2frame)." Wonder if that's what's causing the problem.
     
  20. orchard county

    orchard county Mu-43 Regular

    68
    Apr 11, 2013
    ireland
    I've not had the problem since downloading direct from camera,so I think my card reader was the problem.
    Regards