1. Reminder: Please use our affiliate links for holiday shopping!

OM-D just downloaded firmware 1.5 but I have no idea whats in it

Discussion in 'Olympus Cameras' started by absolutic, Oct 2, 2012.

  1. absolutic

    absolutic Mu-43 Veteran

    416
    Jan 21, 2011
    My OM-D only had firmware 1.0... . so I downloaded the Oly updater in order to download firmware 1.1 (1.2 was suspended I guess). However, the updater took me all the way to firmware 1.5 which got installed. So I have firmware 1.5 now but I have no idea what's in it, there is no indication on Olympus' own site. I am using a Mac. Does anyone know?

    [​IMG]
     
    • Like Like x 4
  2. absolutic

    absolutic Mu-43 Veteran

    416
    Jan 21, 2011
  3. absolutic

    absolutic Mu-43 Veteran

    416
    Jan 21, 2011
    "Operating sounds in the photo ready mode were decreased." The humming sound of OM-D is gone!!!! It only comes on when you half-press the shutter button!!!!! That is nice that that they removed that annoying sound.
     
  4. rcky

    rcky Mu-43 Regular

    61
    Apr 6, 2011
    Washington state
    "Use of the Image stabilizer function by setting the Focal length of an OM lens attached with an adapter was enabled even in Movie mode."

    whoa!
     
    • Like Like x 2
  5. Chrisnmn

    Chrisnmn Mu-43 All-Pro

    Apr 26, 2012
    Auckland, New Zealand
    Chris
    smooth update here! now i have 1.5!. and yes the hum is gone!!!! good stuff Olympus!
     
  6. Idreamphoto

    Idreamphoto Mu-43 Regular

    87
    Sep 1, 2012
    The stabilizer sound seems to be an electronic sound. I wonder how thry can remove the noise without impacting the performance. Any feedback about battery life impact. If so, please share. Thanks.
     
  7. f64

    f64 Mu-43 Regular

    72
    Mar 6, 2010
    Just did the update. My updater showed that I would be updating from 1.2 to 1.4. In the details, it explained that I would need to update a second time, from 1.4 to 1.5.
    Two updates later, I am at 1.5.
    And, as others have said, now there is no hum until the shutter is half-pressed.
    I kind of forgot about the hum, but now I notice it again when I half-press the shutter. I guess I will get used to the hum all over again. :rolleyes:
     
  8. f64

    f64 Mu-43 Regular

    72
    Mar 6, 2010
    From the Olympus update service website:

    Joint update service for OLYMPUS E-SYSTEM - OLYMPUS Digital Camera

    Ver.1.5
    (Oct. 2, 2012)
    - Operating sounds in the photo ready mode were decreased.
    - Use of the Image stabilizer function by setting the Focal length of an OM lens attached with an adapter was enabled even in Movie mode.
    -All updates up to version 1.2 are included.

    Ver.1.4
    (Oct. 2, 2012)
    - Update functions for firmware version 1.2 have been modified. Camera functions are the same as version 1.2. After updating to ver. 1.4, please update the camera to ver. 1.5.

    Ver.1.3
    (Oct. 2, 2012)
    Update functions for firmware prior to version 1.1 have been modified. Camera functions are the same as version 1.1. After updating to ver. 1.3, please update the camera to ver. 1.5.
     
  9. Jonathan F/2

    Jonathan F/2 Mu-43 Hall of Famer

    Aug 10, 2011
    Los Angeles, CA
    Awesome update, I think I'll keep my MF lenses that I was going to sell!

    Please Olympus please add focus peaking!
     
    • Like Like x 2
  10. marklikesit

    marklikesit Mu-43 Regular

    180
    Aug 8, 2012
    Sydney, Australia
    Mark Soon
    Wow. What a huge jump! Thanks for the headsup OP.
     
  11. uci2ci

    uci2ci Mu-43 All-Pro

    Jun 22, 2012
    Los Angeles, CA
    Sam
    YES! listen to this man

     
  12. uci2ci

    uci2ci Mu-43 All-Pro

    Jun 22, 2012
    Los Angeles, CA
    Sam
    So guys, were going to do a "X days without a bricked OM-D" thread :biggrin:...please don't use a USB hubs and don't panic and disconnect/power off the camera if you see a "cannot connect to camera" popup in the updater program....ready,?! commence updating!
     
  13. Chrisnmn

    Chrisnmn Mu-43 All-Pro

    Apr 26, 2012
    Auckland, New Zealand
    Chris
    Keep calm and update your cameras.
     
  14. With_Eyes_Unclouded

    With_Eyes_Unclouded Mu-43 All-Pro

    Apr 17, 2012
    Vassilios
    While they implemented some improvements demanded by users, I'm dissapointed. Where are the existing improvements "already implemented" in the E-PM2/E-PL5? Except if the firmware for the new Pens isn't already finalized, which is the logical conclusion. If that's the case, we will see ver. 1.6 soon.
     
  15. David A

    David A Mu-43 All-Pro

    Sep 30, 2011
    Brisbane, Australia
    Well, I've updated and I still have the hum. It also doesn't change in level when I half press the shutter.

    The info statement said "Operating sounds in the photo ready mode were decreased."

    I think they were decreased and the overall sound level is lower, but it certainly hasn't gone at any stage. I did have to virtually place the camera at my ear to hear it in a quiet room at home.
     
  16. SuzailanJai

    SuzailanJai Mu-43 Regular

    was hoping for smaller AF box like the E-PL5......
     
  17. marklikesit

    marklikesit Mu-43 Regular

    180
    Aug 8, 2012
    Sydney, Australia
    Mark Soon
    Bloody hell, I almost pissed myself during the 1.1 - 1.3 update. My computer froze. All good now.. Onwards to 1.5~!
     
  18. marklikesit

    marklikesit Mu-43 Regular

    180
    Aug 8, 2012
    Sydney, Australia
    Mark Soon
    Yay. Success. The camera's gone so quiet all of a sudden. Not used to it. No more fan noise.
     
  19. tohara

    tohara Mu-43 Rookie

    17
    Jun 5, 2012
    Anyone else having problems updating. I keep getting a failure to communicate :(
     
  20. tohara

    tohara Mu-43 Rookie

    17
    Jun 5, 2012
    Fixed itself....