1. Welcome to Mu-43.com—a friendly Micro 4/3 camera & photography discussion forum!

    If you are thinking of buying a camera or need help with your photos, you will find our forum members full of advice! Click here to join for free!

OM-D E-M5 shutdown problem with Lumix 20mm f/1.7

Discussion in 'Olympus Cameras' started by campbellcj, Jul 5, 2012.

  1. campbellcj

    campbellcj Mu-43 Regular

    39
    Jun 30, 2012
    Hi Everyone,

    I tried to search for existing threads but it seems the forum does not allow searching for short acronyms like "OM-D"...

    I just got this camera and have tried using my trusty Pany 20mm f/1.7 pancake but encountered the mysterious camera shutdown issue several times. The only way to revive the camera is to remove the battery for a moment and then replace it.

    Does anyone here have insight into the problem? I've read posts on other boards but have not seen anything definitive about a response from either Olympus or Panasonic or any way to fix this at present.

    Cheers,
     
  2. uci2ci

    uci2ci Mu-43 All-Pro

    Jun 22, 2012
    Los Angeles, CA
    Sam
  3. rfortson

    rfortson Mu-43 Veteran

    Olympus has acknowledged a problem with the 20/1.7 on the OM-D, though I think they are talking about high ISO banding. Hopefully, they'll address the freezing problem as well. It's well documented, so they should.
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.