1. Reminder: Please use our affiliate links for holiday shopping!

OM-D E-M5 Fn and record button problems

Discussion in 'Olympus Cameras' started by Throttle, Apr 13, 2013.

  1. Throttle

    Throttle Mu-43 Regular

    26
    Jan 11, 2012
    Greater Manchester , UK
    David
    Hi
    I have just got myself a E-M5 and when i press Fn1 , Fn2 and Record button none appear to do anything i have tried a reset and updating too the latest firmware but still no luck :confused:

    I have used a OM-D before so im used too using them but im assuming its faulty unless someone knows of something stupid i might not of noticed yet i doubt it, tried re assigning buttons too different functions as well but nothing seems too work.
    I would like to too say that the dials on top, shutter button and playback button work fine..
    Ive tried auto modes, M, P, S and A modes they all still give the non responsive Fn1, Fn2 and record problem.
     
  2. Ross the fiddler

    Ross the fiddler Mu-43 Hall of Famer

    In the menu, what are the settings in *B for the buttons? They can be set to OFF or any number of different functions.
     
  3. Throttle

    Throttle Mu-43 Regular

    26
    Jan 11, 2012
    Greater Manchester , UK
    David
    In the *B settings page they are at this moment set as
    Fn1 AEL/AFL
    Fn2 Multi function
    Record button is set a record function

    Im just uploading a video on Youtube of it now just too show menu settings for the buttons and the lack of response when there pressed, i'll add it too the thread once its uploaded within next 10 minutes.
     
  4. Throttle

    Throttle Mu-43 Regular

    26
    Jan 11, 2012
    Greater Manchester , UK
    David
  5. Ross the fiddler

    Ross the fiddler Mu-43 Hall of Famer

    I'm sorry, but it does appear the buttons may be faulty.
    In play back mode Fn2 button should lock (protect) the frame being viewed with a green key in the top right hand corner & the Rec button should give a red tick there (marking each frame & following with delete or whatever). Will it do that on yours? If not, then the buttons are faulty & if they do, well..... who knows?
     
  6. Throttle

    Throttle Mu-43 Regular

    26
    Jan 11, 2012
    Greater Manchester , UK
    David
    No the record doesn't start and as mentioned the Fn buttons appear to have no effect, I have owned a OM-D previously but i thought id go and stick with DSLR gear so i sold all my M43 and then regretted it,
    So i started buying it all back so i had a idea of the cameras workings from the past and i was convinced it was the camera faulty and not me selecting wrong settings.

    Thanks for confirming what i thought really :thumbup: It was purchased as new from a eBay seller who i believe was genuine and the camera was all in packing and didn't look used.

    I did email him 3 hours ago asking about a receipt and mentioning the fault but it looks like i will need to raise a dispute on Paypal now as its definitely not right :frown:
     
  7. Halaking

    Halaking Mu-43 Top Veteran

    667
    Dec 17, 2012
    Los Angeles
    Morris
    you may need to update the firmware to 1.6, even the firmware you have now don't have problems, Olympus doesn't allow reinstall firmware, but for new OMD, I believe you have 1.2 or 1.3?, usually reinstall firmware solve the problem, it looks like software problem, just my thought, good luck!
     
  8. Throttle

    Throttle Mu-43 Regular

    26
    Jan 11, 2012
    Greater Manchester , UK
    David
    It had 1.5 installed so i upgraded in hope 1.6 would sort my problem, I wouldn't mind the seller seem nice enough and i have got on to olympus about it..
    Im in the process of selling my 5d mark 2 and 24-70mm f2.8L ..shouldn't have sold my first omd !

    Sent from my GT-I9300 using Tapatalk 2
     
  9. Ross the fiddler

    Ross the fiddler Mu-43 Hall of Famer

    Throttle, you haven't told us if the buttons work in play back mode or not! Can you try them (in play back) & let us know?
     
  10. HarryS

    HarryS Mu-43 Top Veteran

    918
    Jun 23, 2012
    Midwest, USA
    Do a shutter count while you're waiting for Paypal. The results may give you more evidence that it's not only broken, but it could be well used.

    And it is broken.
     
  11. Throttle

    Throttle Mu-43 Regular

    26
    Jan 11, 2012
    Greater Manchester , UK
    David
    Hi
    Sorry about the slow response id been out yesterday after my last post, Shutter count is 96 so it appears only i have used it and the damage log shows nothing.

    In Playback mode the Fn buttons still do nothing when i press them.
     
  12. Ross the fiddler

    Ross the fiddler Mu-43 Hall of Famer

    I'm sorry you now have a faulty camera & hope something can be sorted quickly.