OM-D E-M1 part fallen off my HLD-7 battery grip

amanda

Mu-43 Regular
Joined
Aug 24, 2011
Messages
65
Location
Melbourne, Australia
Hi there,

I noticed the other day that a small square piece is missing from the base of my HLD-7 battery grip. It sits over from the tripod screw. Where you can see into the grip I can see a long silver rod. I'm a bit worried it might damage the grip.

Has anyone had this happen to them too? And does anyone know if Olympus will provide just this small part to me?

Otherwise I'll be buying some gaffa tape then :eek:
 

Empato

Mu-43 Regular
Joined
Mar 25, 2014
Messages
57
Location
Central Scotland.
Just had a look at my HLD-7 grip, and it too has a silver 'pin' protruding, which slots into a hole in the camera body. Not sure if this is what you mean, but if it is, it seems to be the norm.
 

amanda

Mu-43 Regular
Joined
Aug 24, 2011
Messages
65
Location
Melbourne, Australia
Maybe I'll take a photo tonight. I've never noticed it before and it just looks like something is missing.

Might be me too - I won't discount this just yet! :D
 

amanda

Mu-43 Regular
Joined
Aug 24, 2011
Messages
65
Location
Melbourne, Australia
Amanda I think it's where a strap would go if you wanted to carry your camera in that manner. :smile:
Oh that makes sense! That is also a bit embarrassing that I never noticed it before :rolleyes: this is the first grip I've ever owned, never used one on my Canon DSLRs ever.
 
Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Mu-43 is a fan site and not associated with Olympus, Panasonic, or other manufacturers mentioned on this site.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Copyright © 2009-2019 Amin Forums, LLC
Top Bottom