Olympus Workspace + Camera Updater

mrjoemorgan

Mu-43 Veteran
Joined
Feb 1, 2018
Messages
206
Location
San Francisco
Real Name
Joe M
Hi all,

I couldn't find a resolution on any forums so hoping someone can help.

I am running Mac OS 10.15.2 and trying to update my camera software using Olympus Digital Camera Updater through Olympus Workspace

The website says Olympus Workspace supports macOS 10.12 to 10.14 so that might be my issue, but ill continue.

Olympus Workspace installed and updated without issue.

However, whenever I go to Update Camera I get this message:

"The operations of the applications are limited. To use these functions, you need to display the Security & Privacy settings in the system environments setting and allow loading from “Olympus Corporation”, which is blocked."

Screen Shot 2020-01-24 at 3.40.32 PM.png
Subscribe to see EXIF info for this image (if available)
Screen Shot 2020-01-24 at 3.40.45 PM.png
Subscribe to see EXIF info for this image (if available)


I have tried opening my Security & Privacy settings panel to see if there was a restriction to allow, but there is nothing.

I have tried reinstalling everything. No luck. Ill just have to wait for Olympus to update their software for 10.15.2
 
Last edited:

Hendrik

Mu-43 All-Pro
Joined
Feb 27, 2015
Messages
1,410
Location
Wayland MA
Real Name
Hendrik
Please let us know...

There are no Olympus Workspace/Catalina issues being discussed on the Apple Community forums which suggests your problem may be a very low frequency occurrence. Often I find that a restart cures isolated system quirks.
 

mrjoemorgan

Mu-43 Veteran
Joined
Feb 1, 2018
Messages
206
Location
San Francisco
Real Name
Joe M
Uninstalled everything, reinstalled everything. No luck.

I tried on my work laptop, 10.14 and it worked fine. I will use that for now.

Was reading it might be a 32 bit vs 64 bit issue? But that was a post on DP some months ago and might be out of date.
 

Drdul

Mu-43 Veteran
Joined
May 16, 2015
Messages
335
Location
Vancouver, BC
Real Name
Richard
Workspace is trying to install a system kernel extension that it needs to connect to your camera. If you go to System Preferences > Security and Privacy > General you should see a request to approve the kernel extension. Click to approve it. You only have to do this once, even after a Workspace update in the future.

Of course, nothing ever works perfectly, and you may not see the request in System Preferences. You can try installing Workspace again and see if it works the second time. Or you can disable System Integrity Protection, install Workspace and the kernel extension, and then reenable SIP. See https://www.imore.com/how-turn-system-integrity-protection-macos for details. On Catalina you may also have to mount the system volume as writeable (I’m not sure you’ll need to do this, but better to be prepared in case): enter “sudo mount -uw /” in Terminal (without the quotes).
 

Latest posts

Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Mu-43 is a fan site and not associated with Olympus, Panasonic, or other manufacturers mentioned on this site.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Copyright © 2009-2019 Amin Forums, LLC
Top Bottom