Olympus Workspace/Camera Updater and Mac Big Sur 11/3 and/or M1 Chip Not Working

Ranger Rick

Mu-43 Top Veteran
Joined
Apr 11, 2009
Messages
625
Location
Tempe, AZ
Real Name
Rick
Trying to use Olympus Workspace and resulting Camera Updater to save Pen-F settings (have done this many times before on older computer/OS). The Camera Updater launches but popup says it is limited and I must change settings in System Preferences Security settings. Tried that and could not find anything to authorize. I am familiar with this process for a few other apps, which show up in the General tab and you can then allow. No such situation here.

Spoke with Tech Support, they think it must be an OS compatibility issue, and takes a while for software to be updated, but not really sure.

Is anyone running Big Sur 11.3 able to use this capability? Anyone using an M1 Mac able to do so? If so, would appreciate your assistance.
 

mawz

Mu-43 Veteran
Joined
Mar 2, 2013
Messages
264
It's USB and/or file system access in the System Preferences security settings.

They're extremely badly documented and Apple has broken a lot of software because it can't properly adjust security settings automatically. It's not the M1, I had the same issue on my 2014 Mini on Big Sur.

I'll try and post the settings I had to adjust this evening when I'm at my Mac, but it is entirely fixable and no OS compatibility.
 

btolley

New to Mu-43
Joined
Apr 12, 2021
Messages
1
@maws
"It's USB and/or file system access in the System Preferences security settings." Say what???

I tried to do a simple firmware update so my Oly 300mm lens would work with my new 2x teleconvertor and the Olympus updater would not run on Big Sur.

I filed a question with Olympus tech support and they told me Big Sur was not supported. So I pulled out and plugged in my El Capitan iMac to update.
So if you have found a work around, please share. Thx!
 

mawz

Mu-43 Veteran
Joined
Mar 2, 2013
Messages
264
Just checked, and in the Privacy section of the Security & Privacy settings pane I gave OlympusUpdateManager 'Full Disk Access' permissions

In addition, Olympus Workspace should have all 4 options checked in 'Files and Folders' access (OlympusUpdateManager shows up there as well, but is greyed out as it has Full Disk Access permissions)

That got everything working for me. I had the exact same issues before I enabled that access.
 
Joined
Aug 13, 2014
Messages
4,421
Location
Honolulu, HI
Real Name
Walter
Last edited:

Ranger Rick

Mu-43 Top Veteran
Joined
Apr 11, 2009
Messages
625
Location
Tempe, AZ
Real Name
Rick
I will give this a try, thanks Walter. I did gather up the courage to try that Snow app which lets you use the SD card to install the update- nothing happened, so I don't know if that tells me the 2nd Pen F actually has the very latest (same as 1st Pen F) firmware and the OS compatibility is the culprit in saying I don't have latest FW, or whether it simply doesn't work, or wrong phase of the moon or...
Updating via a cable (or now supposedly wifi via the phone app) is such a PITA, so much easier to just put the firmware on an SD card, pop in the camera, and good to go. Just updated my Panasonic G9 to v2.4, a breeze. No cables to scrounge up, yada yada.
 

ffellini

New to Mu-43
Joined
Oct 19, 2021
Messages
2
I managed to make it work. First, find a way to uninstall any previous versions of Olympus Workspace. I did it with the latest version of CleanMyMac. Then perform a clean install of Olympus Workspace.

Before the installation concludes, it will request authorization in System Preferences/Security and Privacy/General. Make sure to authorize it. Then restart.

Before launching the latest version of Olympus Workspace, deactivate any network barriers and VPNs you may be running. Also, check in the System Preferences/Security and Privacy/Firewall that Olympus Workspace is authorized. These were the key steps that made it work.

Connect your camera, turn it on. Then launch Olympus Workspace. I went on straight to the Camera Updater and it could recognize, finally, my OM-D EM-1 Mark III. The update proceeded smoothly for the body and all of my lenses.

(Configuration: MacBook Pro 15" 2016, MacOS Big Sur 11.6)
 
Last edited:

ffellini

New to Mu-43
Joined
Oct 19, 2021
Messages
2
I forgot to add that once operational, the Olympus Camera Updater app managed to upgrade the firmware of my Pen-F as well. Only my Lumix lenses needed upgrading. All the Zuiko glass was OK.
 
Last edited:

martyhs

New to Mu-43
Joined
Nov 10, 2021
Messages
1
After one year (and six calls to Oly tech support) of trying to get Updater to work on my Mac running Big Sur without success (including two calls yesterday), I downloaded OS Monterey last night and, eureka, Updater connected with my camera and worked this morning!!!
 

richjac

New to Mu-43
Joined
Nov 23, 2021
Messages
4
I’m glad you got it to work. I’m running OS Monterey and had no luck updating my new EM-5 mkiii today, there are no critical updates, but I wanted to see if it would work.. I’ll try again tomorrow. Now to see if I can get the OM.share app to work with IOS 15…
 

Latest threads

Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Mu-43 is a fan site and not associated with Olympus, Panasonic, or other manufacturers mentioned on this site.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Forum GIFs powered by GIPHY: https://giphy.com/
Copyright © Amin Forums, LLC
Top Bottom