1. Reminder: Please use our affiliate links for holiday shopping!

Olympus Website Broken

Discussion in 'Open Discussion' started by nstelemark, Oct 5, 2016.

  1. nstelemark

    nstelemark Mu-43 Hall of Famer

    May 28, 2013
    Halifax, Nova Scotia Canada
    Larry
    Is this just me?

    1. The new site is significantly harder to navigate than the old one.

    2. Unbelievably it is also slower. The old one was slow the new one just seems broken most of the time.

    3. Info is missing. Lots of stuff just seems to have vanished.

    4. If you try to load the Canadian site you always get the US site then need to switch - more delays, slow, slow, slow....

    IMO - single page site designs especially not well implemented are not ideal for product centric sites. They are billboards, the Olympus site is not designed to be a billboard. They need to fix this crap ASAP.

    Now I feel better :drinks:
     
    • Agree Agree x 1
  2. Giiba

    Giiba Something to someone somewhere

    273
    Aug 19, 2016
    Burnaby, BC
    Canada? I'm sure that place is made up.

    No it's not just you, the new site is terrible.
     
  3. nstelemark

    nstelemark Mu-43 Hall of Famer

    May 28, 2013
    Halifax, Nova Scotia Canada
    Larry
    Apparently you are correct:

    Screen Shot 2016-10-05 at 9.40.13 PM.png

    :biggrin: At some point when we became the 51st I missed it! :laugh1:
     
    • Funny Funny x 1
    • Sad Sad x 1
  4. Ross the fiddler

    Ross the fiddler Mu-43 Hall of Famer

  5. nstelemark

    nstelemark Mu-43 Hall of Famer

    May 28, 2013
    Halifax, Nova Scotia Canada
    Larry
    • Like Like x 1
  6. alex g

    alex g Mu-43 Top Veteran

    549
    Mar 30, 2016
    New York / Bath
    I've noticed a bunch of incorrectly assigned product images on the US site, particularly in the accessories section. Missing data for most 4/3 lenses too.
    The UK site is pretty good, I find, as a source of product information.
     
  7. Amin Sabet

    Amin Sabet Administrator

    Apr 10, 2009
    Boston, MA (USA)
    Every time I see this thread title, I think someone is saying that our site is broken and I have to fix it :drama:.

    :rofl:
     
    • Funny Funny x 2
  8. Giiba

    Giiba Something to someone somewhere

    273
    Aug 19, 2016
    Burnaby, BC
    Lol, no you know how to create a website. Multi-million dollar corporations are terrible at that apparently.
     
    • Like Like x 1
  9. robcee

    robcee Mu-43 Veteran

    289
    Jan 10, 2016
    Toronto
    Rob Campbell
    Fix it, @Amin Sabet@Amin Sabet! Fix the Olympus site! It broken! Fix it fix it fix it... :dash2:
     
    • Funny Funny x 1
    • Sad Sad x 1
  10. Danny_SWE

    Danny_SWE Mu-43 All-Pro

    Apr 30, 2013
    Sweden (Gothenburg)
    it's overloaded man, everyone is hanging at their homepage pressing F5 to refresh trying to get some new info about EM1Mk2 availability
     
    • Like Like x 1
    • Funny Funny x 1
  11. Giiba

    Giiba Something to someone somewhere

    273
    Aug 19, 2016
    Burnaby, BC
    That only forgives the speed, STOP HITTING F5 PEOPLE, it wont make the camera come out sooner :doh:
     
  12. robcee

    robcee Mu-43 Veteran

    289
    Jan 10, 2016
    Toronto
    Rob Campbell
    • Funny Funny x 1