1. Reminder: Please use our affiliate links for holiday shopping!

Olympus Updater not working

Discussion in 'Olympus Cameras' started by phl0wtography, Oct 30, 2013.

  1. phl0wtography

    phl0wtography Mu-43 Veteran

    227
    Apr 15, 2011
    Hi, I finally got the 25mm/1.4 today, and wanted to update my E-M5 and the lens. Unfortunately the software seems stuck at "Connecting to server" and returns an error saying it cannot connect. My internet is working fine though.
    I tried to
    turn on and off windows7 firewall
    tried it on my MacBook Pro running Maverick, tried over my phones 3G connection acting as a hotspot for my laptop
    tried to plug the PC directly into the modem same with MBP
    rebooted PC
    ran some critical Windows updates.
    I have administration rights on both the windows PC and the MacBook.
    Nothing helped, neither Viewer 3 1.1 nor Camera Updater are able to connect to Oly's servers it seems.
    Are they maybe down/ clogged right now?
     
  2. Sammyboy

    Sammyboy m43 Pro

    Oct 26, 2010
    Steeler Country
    The NSA is gathering information, just be patient and wait your turn.:smile:
     
  3. phl0wtography

    phl0wtography Mu-43 Veteran

    227
    Apr 15, 2011
    You are right. First try today in the morning let me update. Weird
    Anyway, seems that those servers really are under a heavy load sometimes.
     
  4. wjiang

    wjiang Mu-43 Hall of Famer

    I don't think there has been a firmware update for PL25 (H-X025) since release...
     
  5. phl0wtography

    phl0wtography Mu-43 Veteran

    227
    Apr 15, 2011
    No, there is not. I thought there was what with rattlesnaking and all. I updated the body to 1.7 though. Somehow missed that