Olympus Updater Fails to Connect to Camera (OM-D)

Discussion in 'Olympus Cameras' started by c_henry, Jul 12, 2012.

  1. c_henry

    c_henry Mu-43 Regular

    May 12, 2012

    I'm trying to update to the latest firmware. I've connected the camera, fired up the Olympus Digital Camera Updater and clicked the 'Next' button, but get the following errors:

    Camera connected in storage mode:

    Failed to communicate with the camera. (0x4201D)

    Camera connected in MPT mode:

    Unable to use this function on this camera.

    Camera switched off:

    Unable to detect the camera.
    Check if the camera is correctly connected to the PC.​

    So it definitely see's the camera, but for some reason it can't connect.

    Has anyone else experienced this or have any ideas?

    I also fired up Olympus Master 2, but it says it needs an update and then fails to start.

    I'm running OS X Lion 10.7.4 on a Mac Pro with 16GB RAM if that helps.

    Many thanks in advance,

    This ad does not show to logged in members. Click here to register for free.
  2. Chrisnmn

    Chrisnmn Mu-43 All-Pro

    Apr 26, 2012
    Auckland, New Zealand
    Real Name:
    I just updated my camera without any problems. do you have fresh full battery in it?. and its definitely the "storage mode" the one for the updater to connect to the camera. im running on snow leopard though, if that makes any difference.
  3. c_henry

    c_henry Mu-43 Regular

    May 12, 2012
    Well, I've just tried it on my MacBook Air and it seems to be working, had to dig out the Olympus software then connect a DVD drive to it, but as long as it updates I don't care!

    I will try and track down the problem with my main computer though, annoying.

    Appreciate the really quick reply, many thanks,

    • Like Like x 2
  4. rcky

    rcky Mu-43 Regular

    Apr 6, 2011
    Washington state
  5. Chrisnmn

    Chrisnmn Mu-43 All-Pro

    Apr 26, 2012
    Auckland, New Zealand
    Real Name:
  6. D@ne

    D@ne Mu-43 Top Veteran

    Feb 23, 2012
    Apparently there can be issues if a lens is attached to the camera as well. Worth noting if anyone else has any issues.

    I for one cannot find my cable...so it matters not to me. ;)
  7. strang

    strang Mu-43 Veteran

    May 7, 2012
    That cable is apparently a 12-pin Olympus connector. I wish they had gone the way of a standard mini or micro USB connector.
  8. bcaslis

    bcaslis Mu-43 Veteran

    Jul 3, 2011
    Wilsonville, OR, USA
    Real Name:
    Brian Caslis
    I did the update on an iMac running Lion with the lens attached with no problem.
  9. D@ne

    D@ne Mu-43 Top Veteran

    Feb 23, 2012
    No kidding...I have at least 10 of those cables kicking around.

    Not saying everyone will have a problem, but someone mentioned that Olympus wrote something about updating with a lens attached potentially causing issues.
  10. Dave in Wales

    Dave in Wales Mu-43 All-Pro

    Nov 5, 2011
    West Wales

    Just done mine......was a piece-o-cake.....:2thumbs:

    I'm running Windows 7...64 bit.

    Card out, lens off, follow the instructions, click all the boxes.

    Bingo.....OK appeared.

    What I do wish is there was some indication of the download progress.
  11. Muntjack

    Muntjack Mu-43 Regular

    Jul 26, 2010
    Did mine too... 1.1 to 1.2 no problems. I agree the LCD is black for a worryingly long time before it tells you what's going on. It was always thus with the Oly process though.

    I think there was a message somewhere which said the lens needs to be OFF when going from 1.0 to 1.1 but mine arrived at 1.1 anyway so I had the lens on.

    I'm sure the focus confirm beep is louder now, I hardly noticed it before as I'm not all that keen of hearing. If anything it seems to focus even faster too with the PL25.

    I so love this combo.

  12. GaryAyala

    GaryAyala Mu-43 Legend

    Jan 2, 2011
    Finished my updates with OS X.

  13. cmpatti

    cmpatti Mu-43 Veteran

    May 8, 2011
    Berkeley, CA
    Back when I was updating from 1.0 to 1.1, Olympus America Support told me that the update required the lens to be removed from the camera (they said that this issue was one of the things being corrected in the 1.1 update). My update from 1.1 to 1.2 went fine with the lens attached. So, if you're starting at 1.0, try removing the lens before beginning the update.
  14. c_henry

    c_henry Mu-43 Regular

    May 12, 2012
    I've done both of mine with lenses on 1.1 -> 1.2, can't recall what I did on the first one going from 1.0 -> 1.1. but the second one I think came in with 1.1 on it or maybe I didn't upgrade it. I can't recall.

    I've a feeling that my problem stems from the fact that I set the HDD to case-sensitive when I upgraded the disk a month ago. I'll backup this weekend, reformat it and see's if that fixes it.

  15. 250swb

    250swb Mu-43 Regular Charter Member

    The sequence you do things has always been a weak point for Olympus. Maybe you did this, maybe you didn't, but plug the camera into your computer and when the menu appears press the OK button on the camera for 'Storage'. Then fire up Olympus Viewer or the update utility and go to 'update'.

  16. Joe777

    Joe777 Mu-43 Veteran

    Apr 11, 2012
    You need the latest version Olympus Camera Updater Program for it to work, it will not work with earlier programs.
    Also make sure you click OK on the camera when Storage is highlighted, you will then get a blank camera screen. Then the update will start. Follow instructions.
  17. trondkj

    trondkj Mu-43 Rookie

    May 8, 2012
    I have tried to install the latest version of Olympus Camera Updater, but I only get the message that I cannot install it on my computer (MacBook Pro, 2010 model, Os-X Lion installed) I have also tried to use Olympus Viewer 2, but only get a message that it cannot connect to the internet when it shall start downloading. Olympus Master 2 cannot "connect to the camera" when updating, so that is no option either.
  18. Sammyboy

    Sammyboy m43 Pro

    Oct 26, 2010
    Steeler Country
    I believe there's an issue with LION, call Olympus: 1-888-553-4448, they will guide you thru the process.
  19. SkiHound

    SkiHound Mu-43 Veteran

    Jan 28, 2012
    It works on Lion, I did it this morning. But, I had to turn the camera on and then select storage from the choices on the lcd screen. Only then did it recognize my camera. Such a critical process could be described a lot more clearly. And perhaps this is a Lion issue? Why not use SD card updates? Once I got my camera recognized it went fine, but I had exactly the same problem.
  20. 250swb

    250swb Mu-43 Regular Charter Member

    The perennial problem is that people don't press OK for 'Storage' when the camera is first plugged in, but it has always been that way since 4/3rds started. I guess Olympus forget that some new users may not know.

    • Like Like x 2