1. Reminder: Please user our affiliate links to get to your favorite stores for holiday shopping!

Olympus Repair Portal sucks

Discussion in 'Olympus Cameras' started by marcr1230, Mar 10, 2014.

  1. marcr1230

    marcr1230 Mu-43 Regular

    149
    Nov 28, 2013
    I sent my camera in almost 2 weeks ago
    Called a week after it was delivered to them by ups
    It wasn't in the system yet...
    Checked Friday on the web site- it was there finally!

    Today - Monday, I checked again,by order number and serial number and lo and behold no record of it in the web site

    It shouldn't be that hard to get right
    And I shouldn't have to call to track it down
     
  2. IDLookout

    IDLookout Mu-43 Regular

    124
    Apr 26, 2012
    Northern Idaho
    Sounds like what I'm going through. They received my E-M5 Last Monday, still not in the system today. I called and they said "it takes about 5 business days to get into the system but rest assured it is being looked at."

    Ummmm.... Even a quick "We got it" email would have been nice.
     
  3. aidanw

    aidanw Mu-43 Regular

    116
    Nov 19, 2012
    Wellington, NZ
    Out of curiosity, what are you sending yours in for? I am contemplating sending mine in for a sticky pin, which sometimes means I have to re-mount the lens for it to detect it (aperture says "-.-" and the screen is black until the lens is mounted properly).
     
  4. DWhite

    DWhite Mu-43 Regular

    34
    Jun 23, 2013
    David
    I had exactly the same issue. My E-M5 sat in their receiving area for 12 days before being "logged into" their system. I emailed twice and finally called them directly to get it logged in. The helpful person who answered the phone did tell me that they're in the middle up updating their procedures and are experiencing some glitches. She also offered to expedite my return shipping to overnight.

    According to UPS, I'm supposed to receive my E-M5 back today.
     
  5. IDLookout

    IDLookout Mu-43 Regular

    124
    Apr 26, 2012
    Northern Idaho
    I sent my E-M5 in for the "sticky" shutter - black exposures at 1/4000

    Still not in their system, and i even called. lol



     
  6. IDLookout

    IDLookout Mu-43 Regular

    124
    Apr 26, 2012
    Northern Idaho
    Woo Hoo! They must have gotten tired of my calls and emails as now my camera has been "Received" per the Oly site...just over a week after they actually received it.

    Now on to "in Repair", "Out of Repair" and then "Ship Confirmed"...... yikes. Or maybe I'll get it delivered and the week after that it'll go through? lol, why even bother with the web site?
     
  7. Replytoken

    Replytoken Mu-43 Hall of Famer

    May 7, 2012
    Puget Sound
    Ken
    My E-M5 was received last Monday in CT (LCD inspection/replacement), and just posted to their tracking system today, albeit after a number of phone calls. The person I spoke with on several occasions said that they received a large shipment of repairs, and were a bit backed up. I cna understand that, and the staff at Precision seem friendly, but they really need a better system, if only for thier own sake. I have another body follwoing close behind for a sticky shuttter repair/replacement, so I hope they catch up soon. I have a couple of events coming up, and would like to use one or both bodies.

    --Ken
     
  8. marcr1230

    marcr1230 Mu-43 Regular

    149
    Nov 28, 2013
    I partially take back my sucks comment
    Apparently you have to be smart enough to click on the link "repairs submitted after April 1,2013 click here" :)

    Seems like they should make that the first page and link to the old site for old claims

    In any case, waiting a week to get your repair in the system after they've received it seems excessive

    Mine is in for the skipping rear control wheel problem
     
  9. kirio

    kirio Mu-43 Rookie

    10
    Apr 17, 2012
    Bay Area, CA
    I sent an E-M1 for repair, received by them on 2/26. Logged in system on 3/6. Still in repair right now. No additional info on what is taking so long. Olympus customer support was of no use, told me just to wait till end of week with the "may take up to 7 business days to fix". Precision Camera customer service said they'll escalate and look into it and respond within 48 hrs. Sad to say a very disappointing experience so far.
     
  10. marcr1230

    marcr1230 Mu-43 Regular

    149
    Nov 28, 2013
    Now the status is "waiting for parts"
    I just wanted to share my pain
     
  11. heyjohn

    heyjohn New to Mu-43

    9
    Jan 19, 2014
    I sent in mine just for a warranty repair since I bought it used from another put photographer off of this forum. The sensor was a bit dirty and I just wanted them to clean it up. I forgot that I had left the battery in there, so when it came back, it was missing. I called them up and they looked Into it, so now I got a brand new battery coming my way. Also, beware. They mishandled my e-m5 and I got it back with a huge scratch on the bottom screen bezel and a deep knick on the thumb grip. I contacted them and they said to send it back in for repairs.
     
  12. Replytoken

    Replytoken Mu-43 Hall of Famer

    May 7, 2012
    Puget Sound
    Ken
    :frown: Not what I wanted to hear as my camera went from Received to In Repair.

    --Ken
     
  13. mpg01

    mpg01 Mu-43 Regular

    154
    Oct 21, 2012
    My E-M5 is there as well. UPS delivered on 3/4 but it was not logged in to their system until 3/11 and shows as in repair now 3/17. I sent it in for a sensor cleaning. I did just finish reading a LONG list of complaints about the place on line. The bad reviews really just went on and on. Of course when people are satisfied with service they rarely go out of their way to write about it. Perhaps they are in transition but it does not bode well for Olympus to allow this sort of service. Although I guess if they were concerned enough they'd do something about it.

    I agree that the delays would be more palatable if the communication were substantially better. Did you get my camera? Let me know. Was it damaged in transit? I would need to know that to file a claim with the carrier. And so on.

    So, are they THE only game in town for service and support? Because that's the kind of thing that will definitely affect future purchasing decisions.
     
  14. marcr1230

    marcr1230 Mu-43 Regular

    149
    Nov 28, 2013
    The site told me to call them with status "ordering parts"
    I called and after 15 minutes of waiting was told that parts were ordered and it would be 7-10 days until they arrived

    Is it just me, but shouldn't a company selling a camera as professional have an ample supply of parts available to repair the cameras?

    Grrr...
     
  15. heyjohn

    heyjohn New to Mu-43

    9
    Jan 19, 2014
    They wrote back and said to send the camera in again for repairs on the damage they did to my camera the first time I sent it to the shop. Hope they fix it and end up scratching it even more....
     
  16. Crushader

    Crushader Mu-43 Regular

    62
    Dec 11, 2013
    Melbourne, Australia
    Tham
    I sent my VF-4 in for repair here in Australia, it took a week for them to mark as received. I emailed a couple times to chase down the reference number, and only get it by the end of 1st week and said it will be inspected sometimes the week after. Next thing I know, I receive a shipment notice on Monday morning without any further communications from Olympus on my VF-4 inspection results. Hoping they had replaced the faulty unit with a new one without fixing, turned out I received the unit back unfix, they stated there isn't a problem with it.

    They blamed my E-PL5 mismatching the resolution on the VF-4 causing the unsynchronised lines when use in live view... I was pissed but there was nothing I could do, and to my surprise the VF-4 is now functioning properly, no longer have those lines when in live view anymore... I don't even know what they did but they claimed nothing was changed...

    Overall, their turn over time is quite fast, just slow at beginning. But extremely lacking in communications, and no capable system to handle such repair claim. I had to describe my issue with the unit on paper and print it out to send with the unit, horrible system they are running on, absolutely primitive in this day and age.
     
    • Like Like x 1
  17. Replytoken

    Replytoken Mu-43 Hall of Famer

    May 7, 2012
    Puget Sound
    Ken
    Their tracking system indicates that my E-M5 is now being shipped back to me. I am hoping for the best.

    --Ken
     
  18. mpg01

    mpg01 Mu-43 Regular

    154
    Oct 21, 2012
    The status on mine now shows out of repair. Now I just need to see the shipping confirmation bit light up and I'll be home free. Based on the speed of these updates I'm thinking it'll be two more days before it actually moves off the bench and into a box. So that's 11 business days so far for a routine sensor cleaning and system check. I guess it could be much worse.

    It seems that many major brands are using Precision Camera for repairs and I think there may be some affiliation with Best Buy but I'm just sort of piecing together bits of information from here and there. But the complaints of excessive delays and lack of communication seem to be the bulk of the issues with some issues surrounding excessive repair cost quotes and items returned in worse condition than they were sent. I'm just concerned that this is the only game in town.
     
  19. IDLookout

    IDLookout Mu-43 Regular

    124
    Apr 26, 2012
    Northern Idaho
    Mine too now shows out for delivery, but the UPS tracking number isn't in the system yet. It'd be nice if it was here by the weekend but that's wishful thinking on my part..... mostly because my new 25mmf1.8 will be here tomorrow. ;-)
     
  20. sam_m

    sam_m Mu-43 Regular

    182
    Jul 26, 2010
    I have registered my EM-5 to be sent in for repair for the sticking shutter, but now I`m worried about being without it for so long. Widthdrawels will kick in after a week!!