Olympus FL-600R TTL Issues

CarlG

Mu-43 Regular
Joined
Jun 6, 2013
Messages
140
Location
Tampa, FL
Real Name
Carl
I have a relatively new Olympus FL-600R flash attached to my E-M5 and for the life of me, cannot change the mode on the flash to TTL. I used to have this ability before. I only have three options when depressing the mode button - A, M and RC. I should also have two additional TTL modes at my disposal but I do not.

I have tried changing the batteries and reset the flash's settings but still nothing. Never dropped the flash either.

Could it be an inadvertent camera setting preventing this? But I highly doubt it because even with the flash detached from the camera, still no TTL option.

Help please. I checked the web and can't find anything on this. I even read the manual!!! :)
 

sokar

Mu-43 Veteran
Joined
Nov 30, 2011
Messages
395
Maybe it is worth checking the connecting pins and the hot shoe for cleanliness. Ensure the flash is seating all the way onto the hot shoe. A, M and RC modes only would indicate the flash is not connecting with the camera.
 

CarlG

Mu-43 Regular
Joined
Jun 6, 2013
Messages
140
Location
Tampa, FL
Real Name
Carl
Check the flash settings in the SCP on your camera.

I may have stumbled upon the solution by mistake. In the SCP, I had the flash set to "fill" but changed it to 2nd curtain synch and now TTL works. I understand what 2nd curtain synch is but I do not understand why that setting is required in order for the flash to work in TTL mode?
 

CarlG

Mu-43 Regular
Joined
Jun 6, 2013
Messages
140
Location
Tampa, FL
Real Name
Carl
And now that I changed the setting back to "fill in", it still works....this is too strange.
 

hazwing

Mu-43 Hall of Famer
Joined
Nov 25, 2012
Messages
2,152
Location
Australia
I have had this issue in the past, if I have not pushed the flash in all the way properly. It is possible to 'lock' the flash in place, but not have it pushed in all the way and making good contact with the hot shoe.
 

Latest threads

Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Mu-43 is a fan site and not associated with Olympus, Panasonic, or other manufacturers mentioned on this site.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Forum GIFs powered by GIPHY: https://giphy.com/
Copyright © Amin Forums, LLC
Top Bottom