1. Reminder: Please use our affiliate links for holiday shopping!

Olympus e-p3 brick

Discussion in 'Olympus Cameras' started by magicboyguccino, Feb 7, 2012.

  1. magicboyguccino

    magicboyguccino New to Mu-43

    2
    Mar 15, 2011
    Hi!
    After upgrading to 1.2 firmware my e-p3 is not opening.
    How can i solve this problem?
    Is there any key combination to put the camera in to firmware upgrade mode and than try to update the firmware again?
    thanks!
     
  2. Aegon

    Aegon Mu-43 Veteran

    334
    Nov 3, 2011
    Portland, OR
    Olympus Service:
    Customer Service & Repair Center

    (I don't know everything, maybe someone else knows a trick to get you out of this, but I think the camera will have to go to Olympus for service).
     
  3. SRHEdD

    SRHEdD Mu-43 Top Veteran

    967
    Feb 24, 2011
    Viera, Florida USA
    Steve
  4. magicboyguccino

    magicboyguccino New to Mu-43

    2
    Mar 15, 2011

    you are right.
    there must be a button combination to get the machine in to firmware upgrade mode.

    I will be very happy if somebody can help me.

    thanks!
     
  5. TimW

    TimW New to Mu-43

    2
    Apr 9, 2012
    Did you ever find the solution to this as my ep3 is in the same state.
     
  6. fdifulco

    fdifulco Mu-43 Veteran

    251
    Nov 28, 2011
    New Orleans, Louisiana
    Frank
  7. TimW

    TimW New to Mu-43

    2
    Apr 9, 2012
    Interesting site but didn't see any info on recovering from a failed firmware install. Guess it will have to go in for service.