1. Reminder: Please use our affiliate links to get to your favorite stores for holiday shopping!

Olympus charger doing something weird?

Discussion in 'Accessories' started by KS11, Jun 3, 2011.

  1. KS11

    KS11 Mu-43 Veteran

    411
    Jan 31, 2011
    Busan/Hong Kong
    Hi guys, just wondering what is wrong with my olympus charger for my Pen Epl1.

    i put in a empty battery and the orange/red led light starts flashing, does this mean the charger is not charging the battery? is the charger reading the battery as being full? what could be the problem in this case?

    the battery is the original OEM one that came with the camera, so it shouldnt be an issue with the battery eh?

    thanks in advance guys.
     
  2. Ned

    Ned Mu-43 Legend

    Jul 18, 2010
    Alberta, Canada
    Yes, the blinking light does mean that there is a problem. The orange light should stay on solid when charging, and turn blue when the battery is full. The blinking light indicates a problem, but what this could be I don't know...

    Maybe check all your contacts and make sure everything's connecting properly.
     
  3. Djarum

    Djarum Super Moderator

    Dec 15, 2009
    Huntsville, AL, USA
    Jason
    I recommend getting another charger and battery. That way you can determine if it is the charger or the battery. Having an extra charger laying around comes in handy when needing to charge more than one battery at a time anyway, especially when needing both quickly.
     
  4. KS11

    KS11 Mu-43 Veteran

    411
    Jan 31, 2011
    Busan/Hong Kong
    The strangeness continues... I unplugged the connector of the plug with the charger itself then plugged it back in and now it's working fine....although i might get some kind of travel charger soon if this problem persists.
     
  5. Ned

    Ned Mu-43 Legend

    Jul 18, 2010
    Alberta, Canada
    Ah, this could be a faulty connection in the plug adapter to the charger. Make sure that's fit in there snugly. Mine always come apart in the camera bag (all models of Olympus chargers, from the BLM-1 to the BLS-1 to the BLS-5), so I have to snug them in every time anyways.
     
  6. shoturtle

    shoturtle  

    823
    Oct 15, 2010
    it could be the battery not taking a charge or is shorted. I would get a second battery to see if the charger is acting the same. If not the battery went bad, and if you are still within your year warranty and have the receipt, call olympus to get a replacement. Always good to have a spear battery.

    Same for the charger if it went back, and if it is under warranty send it to olympus for a new one.
     
  7. playak47

    playak47 Mu-43 Veteran

    297
    Nov 4, 2010
    I had the same exact problem last weekend. I think it has to do with connection from outlet. I wouldn't worry to much. Test the charger and battery out before you discard it.
     
  8. Basset

    Basset Mu-43 Regular

    69
    Nov 9, 2011
    I will add to this thread because the same just happened to me. Same battery and charger type. You can actually here a slight beep with each flash if you get close enough to the battery. I pulled the battery out, stuck a Wasabi version in, and it charged just fine. So now I will try charge the Olympus batter in the Wasabi charger to see what happens.

    Bought the battery with my EPL3 back in December '11.