1. Reminder: Please use our affiliate links for holiday shopping!

Oly 12-40 and no MF assist on EM5

Discussion in 'Native Lenses' started by kaunitz, Mar 13, 2014.

  1. kaunitz

    kaunitz New to Mu-43

    6
    Mar 13, 2014
    Hello everybody,

    just a short question about my new oly 12-40.

    On my Em-5 when i switch to manual focus from the function butto i configured Mf assist works with no problem, but if i switch to manual focus pulling the ring on the lens there's no way to have the MF assist working?

    Please help.:smile:
     
  2. Swandy

    Swandy Mu-43 Veteran

    362
    Dec 15, 2009
    Same thing that I have on the EM10 and the 17mm/1.8 - only by switching from AF to MF on the camera itself will whatever MF assist. Apparently just using the clutch on the lens does not do it. It does indicate on the camera that I am now in MF mode, but the MF assist (I use Focus Peaking) does not get turned on. (Funny thing is I was playing with a 12-40 at Adorama to judge the size/feel on my EM10 and I would swear that when I just used the clutch on the lens it did activate the Focus Peaking. But certainly does not with the 17mm/1.8 - so maybe I was imagining it.)
     
  3. Sammyboy

    Sammyboy m43 Pro

    Oct 26, 2010
    Steeler Country
    I checked my 12-40 on the M5, the MF clutch works fine, giving MF operation regardless of what the focus setting is on the camera body.
     
  4. mjw

    mjw Mu-43 Veteran

    214
    Sep 23, 2013
    Seattle, WA
    Matt
    They're talking about magnification automatically kicking in when using the clutch.
     
  5. kaunitz

    kaunitz New to Mu-43

    6
    Mar 13, 2014
    So it seems a common "problem" with this mechanism
     
  6. Swandy

    Swandy Mu-43 Veteran

    362
    Dec 15, 2009
    I don't think its a "problem" - I think that the camera firmware is not set up to automatically turn on whatever focus assist you use. When I use a manual lens on my EM10 (Lensbaby or one of several older Olympus lenses with an adapter) the camera will automatically sense the loss of the electrical information coming from the lens and switch to MF. But - I guess because it is dumb - it won't switch on my chosen MF assist. But if I have the camera set for SF+MF (where turning the focusing dial causes Manual Focusing) then my Focus Peaking will start up. I think it is because on the lenses with the MF "clutch", that clutch changes the way the lens focuses from the "focus by wire" which is electrical to a "normal" manually focusing lens.
    I am not an engineer, but when I was surprised that Focus Peaking did not start when I moved the focusing ring on my 17mm/1.8, I called Olympus Tech Support because I thought the lens (a refurbished model) was broken. I was told that this is the correct operation for any of the lenses (the 12mm, 17mm and 12-40mm) that had the manual clutch. (Though I still swear that when I tried the 12-40 on my EM10 in the store, it did turn on Focus Peaking - but I only played with it for a few minutes and might be mistaken.)
     
  7. erwinwee

    erwinwee Mu-43 Rookie

    21
    Jan 20, 2014
    Malaysia
    Erwin Wee
    I do have a EM1 + 12-40mm and the manual focus assist turns on just fine when I pull the MF clutch on the lens, both Magnify + Focus Peaking. Not sure about the EM5 (needs another firmware update from Oly perhaps?) but I'm guessing the EM10 should behave in the same way?
     
  8. kaunitz

    kaunitz New to Mu-43

    6
    Mar 13, 2014
    I'm confused now
    Ok maybe te E-M5 only need a little firmware update
     
  9. letsgofishing

    letsgofishing Mu-43 Veteran

    352
    Nov 21, 2012
    South Africa
    Mike Kaplan
    Just tried my EM5 and 12-40 - works perfectly - pull focus ring - goes to magnified focus straight away.....
     
  10. kaunitz

    kaunitz New to Mu-43

    6
    Mar 13, 2014
    Can you show me your settings?
     
  11. chonbhoy

    chonbhoy Mu-43 Veteran

    430
    Apr 23, 2013
    Scottish Highlands
    I have came across this issue before and posted a thread about it, I assumed it was missed by Olympus originally but now I'm confused that some people have MF assist working using the clutch ring.
    It could be handy having two MF modes one with assist and one without on the fly.
    I just tried the 12mm and when the clutch ring is used MF assist is not working either. I'm using an EM1 FYI.
     
  12. letsgofishing

    letsgofishing Mu-43 Veteran

    352
    Nov 21, 2012
    South Africa
    Mike Kaplan
    Focussing set to S-AF MF....
     
  13. kaunitz

    kaunitz New to Mu-43

    6
    Mar 13, 2014
    Thanks i'll try when at home
     
  14. kaunitz

    kaunitz New to Mu-43

    6
    Mar 13, 2014
    Just tried. Setting camera to S-AF + MF the MF assist works even pulling the clutch
     
  15. chonbhoy

    chonbhoy Mu-43 Veteran

    430
    Apr 23, 2013
    Scottish Highlands
    Must try it too, great if it does.