Older version of Lightroom/PS on new Imac

Discussion in 'Hardware' started by bipinsnair, Oct 14, 2016.

  1. bipinsnair

    bipinsnair Mu-43 Veteran

    311
    Sep 7, 2012
    Herndon, VA
    Bipin Nair
    Need a little bit of advice here as it is difficult to find a direct answer.

    Planning to get a new Imac to replace my 6 year old MacBook Pro running OS X 10.8
    I have older version of Lightoom & PS (post cloud version) on the MacBook.

    I know that the license is good for 2 devices or so, but not sure if I can still install the older version of Lightroom 5 and PS 13.0 on the new OS Sierra on Imac ? Lightroom was upgraded a couple of times to bring it to 5.0 version and I am not sure if I have fresh installer for 5.0.

    Any advice on the compatibility and the install method will be appreciated.

    As an additional question, any experience with 23 vs 27 inch Imac and if there is any other non apple option (all in ones) also can be of help. I see only Mac listed as the platform for PS when I login to my Adobe account and I think it may not work on Windows and hence I am leaning more towards Mac.
     
  2. Bruce McL

    Bruce McL Mu-43 Veteran

    I am running Lightroom 5.7.1 on macOS Sierra 10.12. I am not having any problems; it seems to run just fine.
    I also have PS Elements 10, which runs. It had some problems quitting on 10.11, but seems to run better now.

    Apple's Migration Assistant works well. Run it on the new computer, follow the instructions to connect the old one and it should be able to move all of your apps over from the old to the new computer, along with your documents, music, etc. However you may have a hard time finding a way to connect the two machines. The old one doesn't have thunderbolt, and the new one doesn't have firewire. Apple probably has a way around this, but I don't know what it is offhand. WiFi could take a long time to move everything over.