Old Pana lenses on new Pana body?

Discussion in 'Native Lenses' started by Incalmo, Dec 28, 2013.

  1. Incalmo

    Incalmo New to Mu-43

    Dec 28, 2013
    I've had a Lumix G1 since about 2009-ish (not long after they were released) and like it a lot. Unfortunately the collar switch that chooses shooting mode (Timer, single, multi shot) has failed and it's now stuck on timer. This isn't so bad when shooting with a tripod, but it's a pain at other times. I don't suppose that getting it fixed would be cost-effective, so I'm thinking of getting a G6 body (or maybe G5, I need to compare the features, and figure out if the G6 is worth the extra).

    I already have some lenses:H-FS014045 14-45mm, H-FS045200 45-200mm and H-H014 14mm

    Now to my question. Will my lenses be OK for use with a G6 body?

    I'm about to display my complete ignorance of OIS: The two zoom lenses I own are MEGA OIS. Quite what the implications of this are, I'm not sure. The latest and greatest thing seems to be POWER OIS. Would a G6 (or G5) body be happy with my lenses?

    Are there other reasons why I shouldn't use my "old" (four whole years old!) M4/3 lenses with a new body? NB I won't be using it for video so if there is an issue with noisy AF I don't care about that.

    Thanks in advance, and apols if this is a dumb question. I just don't want to suddenly find that I need to purchase new lenses as well as a new body, and I've searched around without finding a definitive answer.
  2. Jonathan F/2

    Jonathan F/2 Mu-43 Hall of Famer

    Aug 10, 2011
    Los Angeles, CA
    Lenses work fine with no problem!
    • Like Like x 1
  3. Incalmo

    Incalmo New to Mu-43

    Dec 28, 2013
    Thanks for a super-fast response. :) I thought that was probably the case. Just wasn't sure.
  4. jrsilva

    jrsilva Mu-43 All-Pro

    Nov 1, 2012
    Real Name:
    I also own a G1 body with the exact same zooms you have. I don't find any problem using them on my newer G5 or my GX1.
    So, don't worry.
    • Like Like x 1
  5. Incalmo

    Incalmo New to Mu-43

    Dec 28, 2013
    Got my G6! Only had limited time to play with it but all my lenses are working fine! Including, interestingly, a 4/3 Olympus 35mm macro (with m4/3) adapter, which wouldn't auto focus on my g1 but does (albeit stutteringly) on the G6. But perhaps I shouldn't mention that on a native lenses forum.

    Anyway, thanks for the advice.