OI Share "Failed to communicate with the camera"

rlebleu

New to Mu-43
Joined
Apr 15, 2014
Messages
6
New E-M5.3 user. Trying to get O.I. Share to connect to my iPhone 6s running iOS 13.5. After scanning the image, O.I. Share installs bluetooth correctly, shows the correct info from the camera as to Wifi connection then tries to connect with WiFi... The posts "Failed to communicate with the camera". Tried O.I. Share with my E-P5 and it connects perfectly. Tried to connect with an Android phone, and it connects perfectly. On reviewing O.I. Share, E-M5.2 is listed but E-M5.3 is not. Is that the reason it will not connect?
 

PakkyT

Mu-43 Hall of Famer
Joined
Jun 20, 2015
Messages
3,120
Location
New England
No experience with iPhone, but I know with some phones they will "fail" with WiFi is the WiFi does not have any internet access (connects, checks for internet, and disconnects when it fails to find the internet). You might want to go through the WiFi settings of your phone and see if there is a setting you can turn off that allows connecting to a WiFi network regardless of internet status.
 

rlebleu

New to Mu-43
Joined
Apr 15, 2014
Messages
6
Thanks for the quick reply PakkyT. I'm not sure about this because I'm new in the M5 game... But I thought the setup changed the Wifi connection from my internet address to the camera addtress during the setup process... After bluetooth indicatesit's connected properly I get asked if I want to connect to the camera's id address, and after agreeing to this, it tries to connect to the camera and fails.
 

PakkyT

Mu-43 Hall of Famer
Joined
Jun 20, 2015
Messages
3,120
Location
New England
Another thought you can try is trying the connection between the two away from any of the WiFi networks your phone normally connect with. As mentioned, it could be that when your phone doesn't see internet with that network it might immediate auto connect back to your home, work, etc. network. You might try connecting where there are no competing WiFi networks. If it works then it might be after that it will be "trusted". If it still only works when you are away from known WiFi networks, then maybe it it the "no internet" thing with the phone defaulting to the internet ready connections.

As I said, no iPhone here so I can not give any specific suggestions with setting and such.
 

runner girl

Mu-43 Veteran
Joined
Nov 26, 2011
Messages
436
If there are any other nearby WiFi connections I always go to my iphone settings as part of the connection process and make sure the camera is selected. I have the EM5 mkiii and it connects just fine.
 

Hendrik

Mu-43 All-Pro
Joined
Feb 27, 2015
Messages
1,493
Location
Wayland MA
Real Name
Hendrik
I can connect the 5.3 in the normal way with my iPhone Xs (13.4.1). For me normal is:

Start Wifi on camera
Select camera network on phone in Settings/WiFi
Start O.I. Share

This has always seemed to me to work better than starting with O.I. Share open, especially when in the presence of very strong competing signals. Out in the middle of a field, it's probably overkill. It may be that the 5.3 times itself out more quickly than its predecessors.
 

comment23

mu-43 frequent flyer
Joined
Aug 26, 2016
Messages
1,297
Location
Hampshire, UK
Real Name
Simon
The below may not fix the OPs issue but I thought it was worth adding in case it does or if it helps others who come across this thread when having OI.Share connection issues.

——————————

The camera can get confused if your phone is connected to a wifi router with an IP address of 192.168.0.1. This is because it’s the same address as used by FlashAir SD (WiFi enabled) cards. You can see this when opening OI.Share by looking at the bottom bar which may rapidly (about 0.5 sec after starting the app!) change to display ‘FlashAir’.
The camera can get confused if your phone is connected to a wifi router with an IP address of 192.168.0.1. This is because it’s the same address as used by FlashAir SD (WiFi enabled) cards. You can see this when opening OI.Share by looking at the bottom bar which may rapidly (about 0.5 sec after starting the app!) change to display ‘FlashAir’.

Subscribe to see EXIF info for this image (if available)

If you’re really quick you can tap on the ‘Import Photos’ button/bar before this happens and the phone will connect to your camera. Alternatively, the ‘Remote Control’ button/bar appears to bypass this issue.
 
Links on this page may be to our affiliates. Sales through affiliate links may benefit this site.
Mu-43 is a fan site and not associated with Olympus, Panasonic, or other manufacturers mentioned on this site.
Forum post reactions by Twemoji: https://github.com/twitter/twemoji
Copyright © 2009-2019 Amin Forums, LLC
Top Bottom