1. Reminder: Please use our affiliate links for holiday shopping!

OI.Share app not working with E-M5 Mk2

Discussion in 'Olympus Cameras' started by nzdigital, Dec 2, 2015.

  1. nzdigital

    nzdigital Mu-43 Regular

    99
    Oct 20, 2010
    New Zealand
    Wayne
    I have tried, unsuccessfully, over the past 6 months to get the OI.Share app to work with my E-M5 Mk2.

    When I first got the E-M5 about 6 months ago, I tried out the OI.Share app and it connected to the camera and worked perfectly. But when I actually wanted to use the app (for the remote control functionality) a couple of months ago, it just refused to connect with the camera?

    I thought it might need the firmware upgrade, so have waited for the v2 release, which I installed on the E-M5 Mk2 a couple days ago. Re-installed the OI.Share app on my phone to make sure I'm running the latest version of the app (2.6.1), and tried again today to connect the app to my camera. Nothing..... Still the same old 'can't connect to the camera' message.

    I'm using a Samsung S3 running Android 4.3. Admittedly not the latest phone or android operating system, but it DID work the first time I used it with the app and camera.

    There are quite a few bad reviews for the OI.Share app on the play store which basically say that it doesn't work - so is it the app that's the problem, my phone, or the camera?

    The app installs on my phone, it scans the QR code and reads it perfectly, but just won't connect the two devices together...

    Wi-fi isn't a deal breaker for me (I think Olympus's use of it is pretty lame actually), but the remote control function would be nice to have.

    Any thoughts?
     
  2. barry13

    barry13 Super Moderator; Photon Wrangler

    Mar 7, 2014
    Southern California
    Barry
    Hi, does the phone's WiFi stay associated to the camera WiFi, or does it keep switching off or back to your home WiFi?

    Barry
     
  3. nzdigital

    nzdigital Mu-43 Regular

    99
    Oct 20, 2010
    New Zealand
    Wayne
    Hi Barry. It seems to stay associated with the camera. A '1' appears briefly on the camera's lcd screen next to the wifi symbol then disappears as the app tries to establish a connection. I did consider that the wifi at home might be messing with it somehow, so I went outside away from wifi range and tried to connect as well, but got the same message.
     
  4. deltakilo

    deltakilo Mu-43 Rookie

    24
    Nov 12, 2014
    Perth, Australia
    Dennis
    Try going to settings on phone and uninstall the app but be sure to clear the cache and data before clicking uninstall. Reboot phone, reinstall OI Share. That's what worked for me once when the app spat the dummy with my EP5. Kinda standard procedure to follow when any app decides to go bonkers after previously working ok.
     
  5. nzdigital

    nzdigital Mu-43 Regular

    99
    Oct 20, 2010
    New Zealand
    Wayne
    Hi Dennis
    Yep, have done that a few times already.... but did it again just because you told me to ;)

    Same issues. Same problem. Phone keeps telling me it can not connect to the camera.

    This time I even tried manually inputting the connection code and password into the phone. Watched it try to connect from the device manager. Said it could not connect because connection was too low and unstable? My wifi connection at home is very stable and not an issue.

    Sigh.....
     
  6. Clint

    Clint Mu-43 All-Pro

    Apr 22, 2013
    San Diego area, CA
    Clint
    If you getting those notifications then there probably competing WiFi networks. Remove the phone and camera from areas with competing networks. Then try to connect, verify by going into your phones WiFi settings and manually make the connection with the camera. You may have to do the latter a few times before it stays connected, and every time you start the connection.
     
  7. barry13

    barry13 Super Moderator; Photon Wrangler

    Mar 7, 2014
    Southern California
    Barry
    It's also quite possible the phone is looking for the internet via the wifi. I had an HTC that would do that and disconnect, but there is a setting to override that.
    I haven't found a similar setting on my Samsung Note 3, but maybe your phone has it.

    Barry
     
  8. Krigskoen

    Krigskoen Mu-43 Regular

    59
    Jun 10, 2015
    Exactly, that's usually the issue on Samsung phones. Try going into WiFi settings and look for something called Auto network Switch and turn it off
     
    • Agree Agree x 1
  9. jrsilva

    jrsilva Mu-43 All-Pro

    Nov 1, 2012
    Portugal
    Jaime
    I did not yet updated to firmware v.2 on my EM5 MK II.
    But with the firmware 1.2 I'm able to use the OI Share on my Samsung S3 mini with Android 4.1.2.
     
  10. deltakilo

    deltakilo Mu-43 Rookie

    24
    Nov 12, 2014
    Perth, Australia
    Dennis
    Go to the Play Store and install "WiFi Analyser" which is great for showing a visual of wifi networks and your strength in relation to the others. Try doing a wifi reset in the camera's menu "spanner" icon as well in case of a glitch? Failing success with that then the finger looks to point at OI Share as the culprit until its next update.

    Not that it helps you but as a self interest excercise, I did a camera wifi reset and manual password entry on phone 3 times with no problems :)
     
  11. nzdigital

    nzdigital Mu-43 Regular

    99
    Oct 20, 2010
    New Zealand
    Wayne
    BINGO!
    Found it (eventually) and turned it off.
    Connects to the camera now :yahoo:
    Thanks for all your help everyone.